Bug 213379 - The actived affinity of vcpu is not available when the domain is created next time
The actived affinity of vcpu is not available when the domain is created next...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 03:00 EST by mizushima.kazuk@jp.fujitsu.com
Modified: 2010-10-22 02:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 08:51:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mizushima.kazuk@jp.fujitsu.com 2006-11-01 03:00:30 EST
Description of problem:
 The affinity of vcpu is not available after creating a VM based on the
XML file which dumped from a VM with actived affinity.

Version-Release number of selected component (if applicable):
 libvirt-0.1.7-2.src.rpm
  Version     : 0.1.7
  Release     : 2

How reproducible:
 everytime

Steps to Reproduce:
 1.Start domain
   #virsh create /tmp/vm.xml
 2.Modify vcpu affinity
   #virsh vcpupin 1 0 0
 3.Dump xml
   #virsh dumpxml > /tmp/vm1.xml
 4.Stop domain
   #virsh shutdown vm
 5.Start domain
   #virsh create /tmp/vm1.xml

Actual results:
 The affinity of vcpu is not available after createing a VM with the
XML file, which was made by "virsh dumpxml" with actived affinity of vcpu.

Expected results:
 The affinity of vcpu is available after createing a VM with the XML file, 
which was make by "virsh dumpxml" with actived affinity of vcpu.
 It is thought that it is necessary to succeed to the setting of affinity 
because affinity to vcpu can be set with virsh. 

Additional info:
 The XML file which I used is attached.
Comment 1 RHEL Product and Program Management 2006-11-20 12:01:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Veillard 2006-11-22 08:51:56 EST
CPU affinity is actually a result of a policy based on a given context and
not a property of the domain itself. The XML dumps are really pure domain data
and it doesn't sound clean to add those policy informations in the dump itself.
The libvirt API still allow to get and set back those settings, so this should
not block saving and restoring the affinity when saving and restoring a domain.
So declined, further discussions on the tpic should occur upstream in the
libvirt list, see
    http://libvirt.org/bugs.html

Daniel

Note You need to log in before you can comment on or make changes to this bug.