Bug 213385 - Monodevelop does not compile glade projects
Monodevelop does not compile glade projects
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-11-01 03:45 EST by Seby Carta
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-01 04:38:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot of the error and the reference panel (230.91 KB, image/png)
2006-11-01 03:45 EST, Seby Carta
no flags Details

  None (edit)
Description Seby Carta 2006-11-01 03:45:14 EST
Description of problem:

I cannot compile Glade2 C# projects, when i try to compile a new "fresh" glade2
project monodevelop returned me errors:
The type or namespace name `Gtk' could not be found. Are you missing a using
directive or an assembly reference?(CS0246)
The type or namespace name `Glade' could not be found. Are you missing a using
directive or an assembly reference?(CS0246)
If i go on "reference->edit reference", on packages panel i cannot see gtk-sharp
or glade-sharp, but they are installed correctly on mono! because if i compile
externally by command line, the program run fine.

I had this problem also in FC5, and i resolved exporting PKG_CONFIG_PATH in this

export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/lib64/pkgconfig:/usr/share/pkgconfig

but this has no effects on FC6.
I attach the screenshot of the errors.

Version-Release number of selected component (if applicable):
FC6 x86_64
monodevelop 0.12

How reproducible: always

Steps to Reproduce:
1. Create new project C#->glade2.0
2. Try to build the project
Actual results:
SOme error on missing libraries

Expected results:
Building of project

Additional info:
Comment 1 Seby Carta 2006-11-01 03:45:14 EST
Created attachment 139949 [details]
Screenshot of the error and the reference panel
Comment 2 Paul F. Johnson 2006-11-01 03:57:46 EST
Odd. I've just fired up monodevelop, created a new Glade2 project and hit F8 to
build the project and there wasn't a problem.

Could you go to the command line and type

rpm -qa gtk-sharp*

and let me know what you're seeing. It is possible that as FC is using multiple
libs now on 64 bit platforms that you're getting some form of conflict that you
shouldn't (it's happened at this end - I solved it by hosing all the the i386

That said, it's equally possible that I've screwed up somewhere!
Comment 3 Seby Carta 2006-11-01 04:01:09 EST
[root@localhost seby]# rpm -qa gtk-sharp*
Comment 4 Paul F. Johnson 2006-11-01 04:14:11 EST
Okay, I think I know what the problem is now - as a confirmer, can you type

yum -y install gtk-sharp*

and try and run it - I have a feeling I need to change the spec file so that the
-gapi and -devel files are requires.
Comment 5 Seby Carta 2006-11-01 04:16:57 EST

thank you so much
Comment 6 Paul F. Johnson 2006-11-01 04:26:37 EST
Excellent - I thought it would. Out of interest, have you got the
monodevelop-devel package installed?
Comment 7 Seby Carta 2006-11-01 04:29:27 EST
No, i don't have installed monodevelop-devel
[ Note that the same problem is also on FC5 ;-) ]
Comment 8 Paul F. Johnson 2006-11-01 04:38:19 EST
Thanks, I was just making sure before I do a build.

Note You need to log in before you can comment on or make changes to this bug.