This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 213406 - yelp fails to show any search hits
yelp fails to show any search hits
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 06:19 EST by Jens Lautenbacher
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 12:40:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Lautenbacher 2006-11-01 06:19:31 EST
Using the search field in the toolbar of yelp failes to show any hits on even
"easy" searches like "bash" "gnome-terminal" and everything else I threw to it.
Comment 1 Mikko Huhtala 2006-11-05 10:53:40 EST
It works for me. I tried terms like 'bash', 'emacs', 'terminal' (results appear
remarkably quickly, too). The yelp rpm seems to require libbeagle. Does yelp
depend on beagle for searching? Do you have beagle installed? I have

yelp-2.16.0-4.fc6
beagle-0.2.10-5.fc6
libbeagle-0.2.10-5.fc6
Comment 2 Jens Lautenbacher 2006-11-05 12:26:18 EST
beagle-0.2.10-6.fc6
libbeagle-0.2.10-6.fc6
yelp-2.16.0-4.fc6

What is your output from  "beagle-info --list-backends"? Mine is:

EvolutionDataServer  (/usr/lib/beagle/Backends/EvolutionBackends.dll)
EvolutionMail        (/usr/lib/beagle/Backends/EvolutionBackends.dll)
KMail                (/usr/lib/beagle/BeagleDaemonLib.dll)
Files                (/usr/lib/beagle/BeagleDaemonLib.dll)
GaimLog              (/usr/lib/beagle/BeagleDaemonLib.dll)
IndexingService      (/usr/lib/beagle/BeagleDaemonLib.dll)
Tomboy               (/usr/lib/beagle/BeagleDaemonLib.dll)
Blam                 (/usr/lib/beagle/BeagleDaemonLib.dll)
Liferea              (/usr/lib/beagle/BeagleDaemonLib.dll)
Akregator            (/usr/lib/beagle/BeagleDaemonLib.dll)
KonquerorHistory     (/usr/lib/beagle/BeagleDaemonLib.dll)
Kopete               (/usr/lib/beagle/BeagleDaemonLib.dll)


Note that "beagle-config daemon ListBackends" returns

Debug: Loading Beagle.Util.Conf+IndexingConfig from indexing.xml
Debug: Loading Beagle.Util.Conf+DaemonConfig from daemon.xml
Debug: Loading Beagle.Util.Conf+SearchingConfig from searching.xml
Debug: Loading Beagle.Util.Conf+NetworkingConfig from networking.xml
Debug: Loading Beagle.Util.Conf+WebServicesConfig from webservices.xml
Allowed backends:
 - EvolutionDataServer
 - EvolutionMail
 - Files
 - GaimLog
 - IndexingService
 - Tomboy
 - Blam
 - Liferea
 - applications
 - documentation

Denied backends:
 - KMail
 - Kopete
 - KonquerorHistory
 - Akregator

And I assume the "documentation" stuff should normally be used for yelp? I don't
know if the problem is somewhere in beagle, though.
Comment 3 Mikko Huhtala 2006-11-06 18:02:47 EST
From 'beagle-info --list-backends' I get exactly the same output as you, but I
get no 'denied backends' from 'beagle-config daemon ListBackends':

Allowed backends:
 - EvolutionDataServer
 - EvolutionMail
 - KMail
 - Files
 - GaimLog
 - IndexingService
 - Tomboy
 - Blam
 - Liferea
 - Akregator
 - KonquerorHistory
 - Kopete
 - applications
 - documentation

Denied backends:
 (none)

--
The 'documentation' backend is there just the same.

I tried running beagled with the --debug option.When I search for 'emacs' in
yelp, I get

061107 0058396833 03059 Beagle DEBUG: Parsed query 'emacs' as text_query

in the beagle log in 

~/.beagle/Log/2006-11-07-00-57-53-Beagle

So I guess yelp does use beagle (I was not even sure). Do your yelp searches
appear in the log? I'm still running version 0.2.10-5.fc6, because I'm behind a
slow connection at the moment and cannot update.

Comment 4 Jens Lautenbacher 2006-11-13 12:40:22 EST
OK, the problem seems to be not in yelp itself, but beagle.
I saw that /var/cache/beagle/indexes/documentation was very old, and didn't get
updated when running /etc/cron.daily/beagle-crawl-system. 

I removed the whole index directory, run beagle-crawl-system and after a restart
of beagle yelp began showing search hits.

I am not sure why beagle stopped updating the shared indices, but at least one
can be pretty sure it's not the fault of yelp.

Note You need to log in before you can comment on or make changes to this bug.