Bug 213414 - problem with encrypted filesystem on xen-kernel
problem with encrypted filesystem on xen-kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
: Reopened
Depends On:
Blocks: 213517
  Show dependency treegraph
 
Reported: 2006-11-01 07:33 EST by Thorsten Scherf
Modified: 2013-01-09 23:07 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.0.3-2.3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 06:12:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2006-11-01 07:33:52 EST
Description of problem:
when trying to open an encrypted file sytem with luksOpen it fails with an
segmentation fault when using a xen-kernel (2.6.18-1.2798.fc6xen). there is no
problem with the standard kernel (same release). don't know if this is may xen
related.


Version-Release number of selected component (if applicable):
1.0.3-2.1

How reproducible:
cryptsetup luksOpen /dev/sda9 data-crypt
enter the passphrase

Steps to Reproduce:
1.cryptsetup luksOpen /dev/sda9 data-crypt
2.enter the passphrase
3.
  
Actual results:
segmentation fault

Expected results:
successfully unlock the first slot and and create a dm mapping

Additional info:
Comment 1 Peter Jones 2006-11-01 14:23:32 EST
This is because it statically links against libselinux, which at the time it was
built had a broken matchpathcon() function.  Fixed in rawhide.
Comment 2 Daniel Berrange 2006-11-05 16:32:11 EST
Re-opening because this bug is against FC6 not rawhide & no errata has been made
available for either FC6 updates or updates-testing.
Comment 3 Till Maas 2007-07-26 15:19:24 EDT
(In reply to comment #2)
> Re-opening because this bug is against FC6 not rawhide & no errata has been made
> available for either FC6 updates or updates-testing.

Will there be an errata for FC6? I cannot do anything about this, maybe someone
from Redhat will stand in? Peter Jones is afaik too busy to do it.
Comment 4 Till Maas 2007-08-08 06:12:54 EDT
A new release of cryptsetup-luks is now available for FC6 (1.0.3-2.3.fc6), this
should fix this issue, please reopen this bug, when it is not the case.

Note You need to log in before you can comment on or make changes to this bug.