Bug 213416 - airo driver grabs eth0 alias despite modprobe.conf
airo driver grabs eth0 alias despite modprobe.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 07:48 EST by Brad Smith
Modified: 2014-03-16 23:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 19:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Smith 2006-11-01 07:48:19 EST
My Thinkpad T30 has an onboard wired ethernet card using the e100 driver and an
onboard wireless card using the airo driver. Despite the fact that modprobe.conf
aliases eth0 to the wired card and eth1 to the wireless, upon being loaded
during boot it consistently grabs eth0. If I load the e100 driver manually, it
takes over eth0, but even then the airo driver does not take eth1. In order to
have networking function properly I have to manually reload both drivers every
time I boot. 

Here is some illustrative information:

[brad@satsuki ~]$ uname -r
2.6.18-1.2798.fc6

[brad@satsuki ~]$ grep '\(e100\|airo\)' /etc/modprobe.conf
alias eth0 e100
alias eth1 airo

[brad@satsuki ~]$ cat ~/Notes/mac_addrs
eth0: 00:09:6B:CD:2B:87 # built-in wired
eth1: 00:02:8A:A6:30:43 # built-in wireless

[brad@satsuki ~]$ ifconfig eth0   # Note: Wrong mac addr
eth0      Link encap:Ethernet  HWaddr 00:09:6B:CD:2B:87  
          inet6 addr: fe80::209:6bff:fecd:2b87/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:4001 (3.9 KiB)

[brad@satsuki ~]$ ifconfig eth1
eth1: error fetching interface information: Device not found
 
[brad@satsuki ~]$ sudo grep airo /var/log/dmesg  # wireless driver
airo(): Probing for PCI adapters
airo(eth0): Found an MPI350 card
airo(eth0): WPA unsupported (only firmware versions 5.30.17 and greater support
WPA.  Detected 5b00.08)
airo(eth0): MAC enabled 0:2:8a:a6:30:43
airo(): Finished probing for PCI adapters
 
[brad@satsuki ~]$ sudo grep e100 /var/log/dmesg  # wired driver
PCI: Firmware left 0000:02:08.0 e100 interrupts enabled, disabling
e100: Intel(R) PRO/100 Network Driver, 3.5.10-k2-NAPI
e100: Copyright(c) 1999-2005 Intel Corporation
e100: eth1: e100_probe: addr 0xd0204000, irq 11, MAC addr 00:09:6B:CD:2B:87

[brad@satsuki ~]$ sudo modprobe e100
[brad@satsuki ~]$ ifconfig eth0  # Now the mac addr is correct
eth0      Link encap:Ethernet  HWaddr 00:09:6B:CD:2B:87  
          inet6 addr: fe80::209:6bff:fecd:2b87/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:4001 (3.9 KiB)

[brad@satsuki ~]$ ifconfig eth1
eth1: error fetching interface information: Device not found
[brad@satsuki ~]$ sudo modprobe -r airo
[brad@satsuki ~]$ sudo modprobe airo
[brad@satsuki ~]$ ifconfig eth1   # Now this one is correct as well
eth1      Link encap:Ethernet  HWaddr 00:02:8A:A6:30:43  
          inet6 addr: fe80::202:8aff:fea6:3043/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:29 dropped:0 overruns:0 frame:29
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:66 txqueuelen:1000 
          RX bytes:3308 (3.2 KiB)  TX bytes:4681 (4.5 KiB)
          Interrupt:11 Base address:0x8000
Comment 1 John W. Linville 2006-11-01 08:28:29 EST
Can I see the contents of your ifcfg-eth0 and ifcfg-eth1 files?
Comment 2 Brad Smith 2006-11-01 20:41:31 EST
[brad@satsuki network-scripts]$ cat ifcfg-eth0
# Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller
USERCTL=yes
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:09:6B:CD:2B:87
ONBOOT=no
DHCP_HOSTNAME=satsuki.geekdome.net
TYPE=Ethernet


[brad@satsuki network-scripts]$ cat ifcfg-eth1
# AIRONET Wireless Communications Cisco Aironet Wireless 802.11b
USERCTL=yes
DEVICE=eth1
BOOTPROTO=dhcp
HWADDR=00:02:8A:A6:30:43
ONBOOT=no
#DHCP_HOSTNAME=satsuki.geekdome.net
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
TYPE=Wireless
ESSID=
CHANNEL=
MODE=
RATE=

I have several other ifcfg-* files that I use for different profiles, but none
of them have onboot set to yes and all of the are associated with the correct
hwaddr:

[brad@satsuki network-scripts]$ for i in $(grep -li eth0 ifcfg-*); do grep -i
hwaddr $i ; done
HWADDR=00:09:6B:CD:2B:87
HWADDR=00:09:6B:CD:2B:87
HWADDR=00:09:6B:CD:2B:87
HWADDR=00:09:6B:CD:2B:87

[brad@satsuki network-scripts]$ for i in $(grep -li eth1 ifcfg-*); do grep -i
hwaddr $i ; done
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
HWADDR=00:02:8A:A6:30:43
Comment 4 Bill Nottingham 2006-11-29 14:45:41 EST
Please try the updates-testing initscripts and kudzu. Note that 'alias XXX' in
modprobe.conf isn't really used any more.
Comment 5 Craig Kelley 2006-12-18 11:14:50 EST
We have this same problem with a tg3 and an rt8152 card.  It RANDOMLY picks one
at boot time to use as eth0/1.  How do we enforce a particular order if
modprobe.conf isn't used any longer?
Comment 6 Bill Nottingham 2006-12-18 11:58:30 EST
Add HWADDR= lines to your ifcfg files, and make sure you're running the latest
updates.
Comment 7 Craig Kelley 2006-12-18 14:25:12 EST
And if we're duplicating drive images for thousands of machines?  We have to
individually set the HWADDR lines on each image by hand?

This breaks the behavior of all previous versions of redhat/fedora (we've been
using it since RedHat 7.3).
Comment 8 Bill Nottingham 2006-12-18 14:26:36 EST
Then open up a bug against udev - there is very little initscripts can do in
this matter other than attempt to clean up afterwards with the HWADDR code.
Comment 9 Craig Kelley 2006-12-18 14:44:42 EST
Thanks Bill; there's already one there (bug 212869)
Comment 10 Bill Nottingham 2007-04-16 19:48:09 EDT
Closing; mismatches when HWADDR is present should be fixed with the current
errata  initscripts/kudzu.

Note You need to log in before you can comment on or make changes to this bug.