Bug 213453 - Building kopete from svn source fails
Building kopete from svn source fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 10:45 EST by Daniel Meissner
Modified: 2008-01-06 16:39 EST (History)
0 users

See Also:
Fixed In Version: Fedora 7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 16:39:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of make (4.80 KB, application/octet-stream)
2006-11-01 10:45 EST, Daniel Meissner
no flags Details

  None (edit)
Description Daniel Meissner 2006-11-01 10:45:53 EST
Description of problem:
Building the cvs version of kopete fails. Error Message is:
/usr/include/linux/videodev2.h:716: error: '__s64' does not name a type

There is also a KDE bug report but the workaround suggested there doesn't fix
the problem for me.
http://bugs.kde.org/show_bug.cgi?id=135853
Comment 1 Daniel Meissner 2006-11-01 10:45:54 EST
Created attachment 139995 [details]
output of make
Comment 2 Daniel Meissner 2006-11-03 11:59:32 EST
After massive google-use I found a working solution (for me). Add

typedef __signed__ long long __s64;

at the top in /usr/include/linux/videodev2.h

Confirmed on a fresh as well as on an upgraded FC6 installation.
Comment 3 Mike Pope 2006-11-17 05:58:35 EST
This has bitten me on code that ultimately includes <asm/byteorder.h>.  I saw 
it because the included <asm/types.h> does not define __s64 or __u64 if 
__STRICT_ANSI__ is set.  This may be a mistaken attempt to avoid using the 
long long types in ``ANSI C'', which makes sense for C89 but *not* for C99.  
Something that checks if __STDC_VERSION__ < 199901L would be better.  
<linux/types.h> makes the same mistake with the __le64 and __be64 types.

<asm/byteorder.h> also uses "asm" in one spot, and "__asm__" in another.  The 
latter is preferrable.

Finally, the package containing these files is no longer glibc-kernheaders:
 rpm -qf /usr/include/asm/byteorder.h => kernel-headers-2.6.18-1.2849.fc6
on FC6.  Bugzilla however has no entry for kernel-headers.
Comment 4 Till Maas 2008-01-06 16:39:07 EST
Should be fixed in Fedora 7. The correct component for this bug is now kernel,
because the kernel-headers package is built from the kernel srpm (spec).

Note You need to log in before you can comment on or make changes to this bug.