Bug 213499 - Repomd generation ignores 'interesting' files in primary.xml
Repomd generation ignores 'interesting' files in primary.xml
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn415
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Beth Nackashi
:
Depends On:
Blocks: 189170
  Show dependency treegraph
 
Reported: 2006-11-01 13:04 EST by James Bowes
Modified: 2013-01-10 04:51 EST (History)
2 users (show)

See Also:
Fixed In Version: RHN415
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 15:35:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2006-11-01 13:04:26 EST
primary.xml contains a section for 'interesting' files provided by a package (ie
those in *bin or *etc). We don't include this information, and so if a package
requires, say, /usr/bin/m4, it will not be able to resolve the dependency.
Comment 1 Beth Nackashi 2006-11-01 13:12:26 EST
Here's what the error looks like:

Error: Missing Dependency: /usr/bin/m4 is needed by package redhat-lsb
Error: Missing Dependency: /usr/bin/ar is needed by package redhat-lsb
Error: Missing Dependency: /usr/bin/strip is needed by package redhat-lsb

I found this while trying to use yum to update a beta 1 client to beta 2.
Comment 2 James Bowes 2006-11-01 14:40:08 EST
The fix is in rhns-4.1.5-22
Comment 3 Beth Nackashi 2006-11-01 17:47:53 EST
[root@dhcp59-145 ~]# yum update redhat-lsb
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package redhat-lsb.i386 0:3.1-11 set to be updated
--> Running transaction check
--> Processing Dependency: /usr/bin/strip for package: redhat-lsb
--> Processing Dependency: /usr/bin/m4 for package: redhat-lsb
--> Processing Dependency: /usr/bin/ar for package: redhat-lsb
--> Finished Dependency Resolution
Error: Missing Dependency: /usr/bin/strip is needed by package redhat-lsb
Error: Missing Dependency: /usr/bin/m4 is needed by package redhat-lsb
Error: Missing Dependency: /usr/bin/ar is needed by package redhat-lsb

[root@scripts ~]# rpm -q rhns
rhns-4.1.5-22.rhel4


Do I need to re-register this client or something?
Comment 4 Beth Nackashi 2006-11-01 17:51:28 EST
Pradeep suggested clearing the cache, which I did.  And now it works!

[root@dhcp59-145 yum]# yum update redhat-lsb
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for redhat-lsb to pack into transaction set.
redhat-lsb-3.1-11.i386.rp 100% |=========================|  11 kB    00:00
---> Package redhat-lsb.i386 0:3.1-11 set to be updated
--> Running transaction check
--> Processing Dependency: /usr/bin/strip for package: redhat-lsb
--> Processing Dependency: /usr/bin/m4 for package: redhat-lsb
--> Processing Dependency: /usr/bin/ar for package: redhat-lsb
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for m4 to pack into transaction set.
m4-1.4.5-3.i386.rpm       100% |=========================| 6.4 kB    00:00
---> Package m4.i386 0:1.4.5-3 set to be updated
---> Downloading header for binutils to pack into transaction set.
binutils-2.17.50.0.6-1.el 100% |=========================|  45 kB    00:00
---> Package binutils.i386 0:2.17.50.0.6-1.el5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 redhat-lsb              i386       3.1-11           rhel-i386-server-5-beta   21 k
Installing for dependencies:
 binutils                i386       2.17.50.0.6-1.el5  rhel-i386-server-5-beta 2.9 M
 m4                      i386       1.4.5-3          rhel-i386-server-5-beta  133 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 3.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): m4-1.4.5-3.i386.rp 100% |=========================| 133 kB    00:00
(2/3): binutils-2.17.50.0 100% |=========================| 2.9 MB    00:00
(3/3): redhat-lsb-3.1-11. 100% |=========================|  21 kB    00:00
Running Transaction Test
warning: m4-1.4.5-3: Header V3 DSA signature: NOKEY, key ID 897da07a
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: binutils                     ######################### [1/4]
  Installing: m4                           ######################### [2/4]
  Updating  : redhat-lsb                   ######################### [3/4]
  Cleanup   : redhat-lsb                   ######################### [4/4]

Dependency Installed: binutils.i386 0:2.17.50.0.6-1.el5 m4.i386 0:1.4.5-3
Updated: redhat-lsb.i386 0:3.1-11
Complete!
Comment 5 Brandon Perkins 2006-11-09 15:35:12 EST
closing -- current release.  RHN415 is now in production.

Note You need to log in before you can comment on or make changes to this bug.