Bug 213505 - Error updating kdepim-devel and kdegraphics-devel via yum (in x86_64)
Error updating kdepim-devel and kdegraphics-devel via yum (in x86_64)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Ben Levenson
:
: 214108 215970 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 13:40 EST by Alberto Planas
Modified: 2016-09-19 22:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 16:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alberto Planas 2006-11-01 13:40:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.8.0.7) Gecko/20061027 Fedora/1.5.0.7-8.fc6 Firefox/1.5.0.7

Description of problem:
In a fresh FC6 install I do:

# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kdegraphics.x86_64 7:3.5.5-0.1.fc6 set to be updated
---> Package kdepim-devel.x86_64 6:3.5.5-0.1.fc6 set to be updated
---> Package kdegraphics-devel.x86_64 7:3.5.5-0.1.fc6 set to be updated
---> Package kdepim-devel.i386 6:3.5.5-0.1.fc6 set to be updated
---> Package kdegraphics-devel.i386 7:3.5.5-0.1.fc6 set to be updated
---> Package kdepim.x86_64 6:3.5.5-0.1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libkghostviewlib.so.0 for package: kdegraphics-devel
--> Processing Dependency: libkpinterfaces.so.1 for package: kdepim-devel
--> Processing Dependency: libkorganizer.so.1 for package: kdepim-devel
--> Processing Dependency: libkpgp.so.2 for package: kdepim-devel
--> Processing Dependency: libkorganizer_eventviewer.so.1 for package: kdepim-devel
--> Processing Dependency: libkpimidentities.so.1 for package: kdepim-devel
--> Processing Dependency: libkpilot.so.0 for package: kdepim-devel
--> Processing Dependency: libksieve.so.0 for package: kdepim-devel
--> Processing Dependency: libkcal.so.2 for package: kdepim-devel
--> Processing Dependency: libkgantt.so.0 for package: kdepim-devel
--> Processing Dependency: libkgroupwaredav.so.0 for package: kdepim-devel
--> Processing Dependency: libkslox.so.0 for package: kdepim-devel
--> Processing Dependency: libindex.so.0 for package: kdepim-devel
--> Processing Dependency: libkpimexchange.so.1 for package: kdepim-devel
--> Processing Dependency: libkorganizer_calendar.so.1 for package: kdepim-devel
--> Processing Dependency: libkabc_groupwise.so.1 for package: kdepim-devel
--> Processing Dependency: libkcal_slox.so.0 for package: kdepim-devel
--> Processing Dependency: libkcal_resourceremote.so.1 for package: kdepim-devel
--> Processing Dependency: libkcal_xmlrpc.so.1 for package: kdepim-devel
--> Processing Dependency: libtext2path.so.0 for package: kdegraphics-devel
--> Processing Dependency: libknoteskolab.so.0 for package: kdepim-devel
--> Processing Dependency: libkgroupwarebase.so.0 for package: kdepim-devel
--> Processing Dependency: libmultisynk.so.0 for package: kdepim-devel
--> Processing Dependency: libksync2.so.0 for package: kdepim-devel
--> Processing Dependency: libkcalkolab.so.0 for package: kdepim-devel
--> Processing Dependency: libkitchensyncui.so.0 for package: kdepim-devel
--> Processing Dependency: libkode.so.1 for package: kdepim-devel
--> Processing Dependency: libknotes_xmlrpc.so.1 for package: kdepim-devel
--> Processing Dependency: libksync.so.1 for package: kdepim-devel
--> Processing Dependency: libkocorehelper.so.1 for package: kdepim-devel
--> Processing Dependency: libqgpgme.so.0 for package: kdepim-devel
--> Processing Dependency: libkcal_groupwise.so.1 for package: kdepim-devel
--> Processing Dependency: libkimageviewer.so.0 for package: kdegraphics-devel
--> Processing Dependency: libkabc_newexchange.so.1 for package: kdepim-devel
--> Processing Dependency: libkabinterfaces.so.1 for package: kdepim-devel
--> Processing Dependency: libkcal_resourcefeatureplan.so.1 for package: kdepim-devel
--> Processing Dependency: libkorg_stdprinting.so.1 for package: kdepim-devel
--> Processing Dependency: libkcal_groupdav.so.1 for package: kdepim-devel
--> Processing Dependency: libkmultipage.so.0 for package: kdegraphics-devel
--> Processing Dependency: libktnef.so.1 for package: kdepim-devel
--> Processing Dependency: libkabc_slox.so.0 for package: kdepim-devel
--> Processing Dependency: libkholidays.so.1 for package: kdepim-devel
--> Processing Dependency: libkscan.so.1 for package: kdegraphics-devel
--> Processing Dependency: libkmime.so.2 for package: kdepim-devel
--> Processing Dependency: libksvg.so.0 for package: kdegraphics-devel
--> Processing Dependency: libkabc_groupdav.so.1 for package: kdepim-devel
--> Processing Dependency: libkdepim.so.1 for package: kdepim-devel
--> Processing Dependency: libgpgme++.so.0 for package: kdepim-devel
--> Processing Dependency: libkonnector.so.0 for package: kdepim-devel
--> Processing Dependency: libkabckolab.so.0 for package: kdepim-devel
--> Processing Dependency: libkontact.so.1 for package: kdepim-devel
--> Processing Dependency: libkleopatra.so.1 for package: kdepim-devel
--> Processing Dependency: libkcal_newexchange.so.1 for package: kdepim-devel
--> Processing Dependency: libkabc_xmlrpc.so.1 for package: kdepim-devel
--> Processing Dependency: libkaddressbook.so.0 for package: kdepim-devel
--> Processing Dependency: libmimelib.so.1 for package: kdepim-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libkghostviewlib.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libkpinterfaces.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpgp.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer_eventviewer.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpimidentities.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpilot.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libksieve.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcal.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libkgantt.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkgroupwaredav.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkslox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libindex.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkpimexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer_calendar.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_groupwise.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_slox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_resourceremote.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libtext2path.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libknoteskolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkgroupwarebase.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libmultisynk.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libksync2.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcalkolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkitchensyncui.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkode.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libknotes_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libksync.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkocorehelper.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libqgpgme.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_groupwise.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkimageviewer.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libkabc_newexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabinterfaces.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_resourcefeatureplan.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorg_stdprinting.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_groupdav.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkmultipage.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libktnef.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_slox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkholidays.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkscan.so.1 is needed by package kdegraphics-devel
Error: Missing Dependency: libkmime.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libksvg.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libkabc_groupdav.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkdepim.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libgpgme++.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkonnector.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkabckolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkontact.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkleopatra.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_newexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkaddressbook.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libmimelib.so.1 is needed by package kdepim-devel

But thoose libs are in /usr/lib64:
$ ls /usr/lib64/libmimelib.so.1
/usr/lib64/libmimelib.so.1



Version-Release number of selected component (if applicable):
kdepim-devel.x86_64 6:3.5.5-0.1.fc6

How reproducible:
Always


Steps to Reproduce:
1. yum update


Actual Results:


Expected Results:


Additional info:
Workarround:

yum update --exclude=kdepim-devel --exclude=kdegraphics-devel --exclude=kdepim --exclude=kdegraphics
Comment 1 Tomasz Kepczynski 2006-11-02 00:48:37 EST
I have exactly the same problem.
Comment 2 Ngo Than 2006-11-02 11:03:25 EST
it's a bug in distribution. The following 32bit packages are missing.

kdeedu-3.5.5-0.1.fc6.i386
kdepim-3.5.5-0.1.fc6.i386
kdegraphics-3.5.5-0.1.fc6.i386
kdeutils-3.5.5-0.1.fc6.i386
kdebindings-devel-3.5.5-0.1.fc6.i386


Tim, it's effected in rhel5 tree too.



Comment 3 Ngo Than 2006-11-02 11:04:17 EST
correct list

kdeedu-3.5.5-0.1.fc6.i386
kdepim-3.5.5-0.1.fc6.i386
kdegraphics-3.5.5-0.1.fc6.i386
kdeutils-3.5.5-0.1.fc6.i386
kdebindings-3.5.5-0.1.fc6.i386
Comment 4 Jesse Keating 2006-11-04 17:11:28 EST
This appears to be a KDE packaging bug.

kdeedu main package has 
/usr/lib64/libkiten.la
/usr/lib64/libkiten.so
/usr/lib64/libkiten.so.1
/usr/lib64/libkiten.so.1.0.0

and many more.  Firstly .la files shouldn't be packaged unless absolutely
necessary.  Secondly, the .so file should be in the -devel package.  This would
make the -devel package for a given arch require the base package for that same
arch.  What we have now is the -devel package not requiring the arch specific
base package, and thus it isn't getting pulled in for multilib.

same for kdepim

same for kdegraphics

same for kdebindings

kdeutils was blocked from being multilib as it was making python multilib and
breaking.

These are all problems in the shipped FC6, and the updates are based on what
shipped multilib for FC6 so the problem continues.  These packaging bugs need to
be fixed in order to have multilib work right for kde packages.

I'm reassigning to than to fix the packaging bugs.
Comment 5 Ngo Than 2006-11-06 10:41:51 EST
Jesse, it's a bug in previous version of kde packages which have included .so 
files in base packages. The new kde-3.5.5 now fixes this issue, the .so 
symlinks now are moved in -devel package. 

With this fix in KDE packages, it's really needed that we have to push the 
above missing base packages into FC6/FC5 update tree!


Comment 6 Jesse Keating 2006-11-06 10:46:36 EST
Luke, can you make this happen?  (and mark these as multilib for future updates?)
Comment 7 Luke Macken 2006-11-12 16:07:25 EST
I added kde{edu,pim,graphics,bindings} to the FC{5,6} multilib lists, and
repushed  updates #1103 and #1104.

Please let me know if I missed/forgot/broke something.
Comment 8 Ngo Than 2006-11-17 07:20:26 EST
*** Bug 214108 has been marked as a duplicate of this bug. ***
Comment 9 Ngo Than 2006-11-17 07:21:43 EST
*** Bug 215970 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.