Bug 213506 - Cannot read more hard disks and X doesn't start and I cannot login
Cannot read more hard disks and X doesn't start and I cannot login
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 13:42 EST by Amr Hamdy
Modified: 2008-05-06 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amr Hamdy 2006-11-01 13:42:30 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Hello all great people of fedora and redhat :) ,
I've faced too many problems with this new release of fedora which I didn't face
ever ...
The one I'm reporting here is .. After installing fedora with KDE and Gnome it
started nomally but after that I shutted it down , attached a new hard disk as
slave and it started PC again ..
I've installed fedora on a Western Digital 80 GB hard disk and it's a primary
master ATA drive ..
The new hard disk I've attached after installation is western digital 120 GB
hard disk.. I've tried to attach it as primary slave and secondary slave ... 

After starting FC6 , X didn't start and I cannot login ... I tried to login with
username "root" or another username I've created, "amr", but both failed ..
I'm 100% that I've typed the usenames and pasword correctly on the console ... 
  I've tried many times to login at console but it failed ..

another very strange thing is that I cannot find any thing in the logs regarding
this issue ...


Steps to Reproduce:
1.Install fedora core
2.Attach new hard disk after installation
3.It will fail
  
Actual results:
Every thing just failed as I described ... failed to login ... X didn't start ..
you can just do nothing .. nothing at all but to detach the new harddisk again

Expected results:
Every thing should work normally ...


Additional info:
Comment 1 Bill Nottingham 2006-11-01 13:56:29 EST
There's nothing about adding another hard drive that should cause other things
to fail, unless you ended up accidentally booting a different OS off that other
hard drive.

Does it work if you remove the addded drive?
Comment 2 Amr Hamdy 2006-11-02 04:27:14 EST
Yes yes it worked very fine when I removed the added drive ...
I could found the reason and could solve the problem ..

I'd a corrupted FC6 installation on the added drive .. so the filesystem there
had the same LABEL so it got mounted as "/" instead of the right one on the main
hard disk .. 

This is another problem ... why when there is duplicated LABELs of filesystems
it mounts the last one it finds? it should mount the first filesystem with that
LABEl not the last one ... 
Comment 3 Bill Nottingham 2006-11-02 11:40:36 EST
That would be a mkinitrd issue - assigning there.
Comment 4 Need Real Name 2007-03-22 12:11:49 EDT
Make sure both the selector jumpers and cables to new disks are properly set to
recognize primary and secondary and boot selection.
Comment 5 Amr Hamdy 2007-03-23 08:42:37 EDT
Yes of course, it was ... 
The problem is that when you mount the root filesystem by LABEL in /etc/fstab
and that there are two filesystems with the same label fedora will mount the
last one in order not the 1st one ... 

Comment 6 Bug Zapper 2008-04-04 00:19:39 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 12:39:17 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.