Bug 213521 - kmix wont recognize hotkeys (global shortcuts) after latest update.
kmix wont recognize hotkeys (global shortcuts) after latest update.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
6
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 14:59 EST by jlo
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlo 2006-11-01 14:59:36 EST
Description of problem:
kmix wont recognize hotkeys (global shortcuts) after latest update
kdemultimedia-3.5.5-0.1.fc6

Version-Release number of selected component (if applicable):
kdemultimedia-3.5.5-0.1.fc6.i386
kdemultimedia-3.5.5-0.1.fc6.x86_64

How reproducible:


Steps to Reproduce:
1. Open Kmix. Go to settings > configure global shotcuts.
2. Assign a key and save. 

  
Actual results:
Kmix wont react when trying to use hotkeys. Mute, volume up, or volume down for
example.

Expected results:
It should work.

Additional info:
Comment 1 Kristo Kriechbaum 2006-12-30 00:32:04 EST
I have the same issue - but its just my volume up key doesn't work.  Volume down
and mute work, but I don't get the window in the middle of the screen indicating
that anything happened (like I used to).  If I mute, the kmix tray icon gets the
slash through it indicating mute, but I don't get the window in the middle of
the screen saying "mute on" (or something like that)

The same (I think) issue is discussed here:
https://launchpad.net/distros/ubuntu/+source/kdebase/+bug/37341

I use the "Logitech Cordless Desktop Pro" layout, or "logicdp". 
/usr/share/X11/xkb/symbols/inet has 2 symbols defined for XF86AudioRaiseVolume.
 If I run 
   xmodmap -e "keycode 175 ="
my volume up starts working, and I also get the window that pops up that shows
what setting the volume is at.  volume down and mute continue to work after
that, but still no window showing the volume setting.

I think this bug is related to bug #203258

I'm willing to change a few files, etc, to help out.  Just let me know what I
can do.
Comment 2 Lukáš Tinkl 2008-01-02 07:42:37 EST
Could you pls reproduce against the current version (F8)? It looks like a 
keyboard layout bug (xorg problem) rather than a KDE bug
Comment 3 Bug Zapper 2008-04-04 00:20:11 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2008-05-06 12:39:32 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.