Bug 213535 - mkqdisk -f <label> does not work
mkqdisk -f <label> does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 16:26 EST by Lon Hohberger
Modified: 2009-04-16 18:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2006-11-01 16:26:41 EST
+++ This bug was initially created as a clone of Bug #213218 +++

Description of problem:

the "-f <label>" option does not work

Version-Release number of selected component (if applicable):
mkqdisk v0.5, cman-1.0.11-0

How reproducible:

every time

Steps to Reproduce:
1. (on an EMC array running PowerPath) mkqdisk -c /dev/emcpowera1 -l quorum_disk_1
2. mkqdisk -f quorum_disk_1
  
Actual results:

Only qdisk version number is displayed

Expected results:
(as per the mkqdisk man page):
Find the cluster quorum disk with the given label and display information about it..

-- Additional comment from lhh@redhat.com on 2006-10-31 09:53 EST --
Definitely a bug.  -f should work.  (-L does).

-- Additional comment from lhh@redhat.com on 2006-10-31 09:57 EST --
Created an attachment (id=139856)
Fixes behavior


-- Additional comment from lhh@redhat.com on 2006-10-31 10:04 EST --
Created an attachment (id=139858)
Above patch missed something.

[root@red qdisk]# ./mkqdisk -L
mkqdisk v0.5.1
/dev/sdb1:
	Magic:	 eb7a62c2
	Label:	 foo
	Created: Thu Jun 22 17:47:35 2006
	Host:	 red.lab.boston.redhat.com

[root@red qdisk]# ./mkqdisk -f bar
mkqdisk v0.5.1
[root@red qdisk]# ./mkqdisk -f foo
mkqdisk v0.5.1
/dev/sdb1:
	Magic:	 eb7a62c2
	Label:	 foo
	Created: Thu Jun 22 17:47:35 2006
	Host:	 red.lab.boston.redhat.com


-- Additional comment from lhh@redhat.com on 2006-10-31 10:06 EST --
Do you want me to build test RPMs, or would you like to build qdisk?

-- Additional comment from riaan@obsidian.co.za on 2006-11-01 05:35 EST --
test RPM, please

-- Additional comment from lhh@redhat.com on 2006-11-01 15:59 EST --
Created an attachment (id=140035)
i686 test package


-- Additional comment from lhh@redhat.com on 2006-11-01 16:00 EST --
Created an attachment (id=140036)
source rpm


-- Additional comment from riaan@obsidian.co.za on 2006-11-01 16:16 EST --
the patch works for me too:

[sargas:~]# mkqdisk -f quorum_disk_1
mkqdisk v0.5.1
/dev/sdc1:
        Magic:   eb7a62c2
        Label:   quorum_disk_1
        Created: Mon Oct 30 16:15:57 2006
        Host:    sargas.telkomsa.net

[sargas:~]# mkqdisk -f quorum_disk_2
mkqdisk v0.5.1
Comment 1 RHEL Product and Program Management 2006-11-01 16:40:29 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 RHEL Product and Program Management 2006-12-22 20:57:24 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.
Comment 3 Nate Straz 2007-12-13 12:22:09 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.