Bug 21355 - as seems unable to compile 2.4.0 kernel .modinfo section tags
Summary: as seems unable to compile 2.4.0 kernel .modinfo section tags
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-26 17:25 UTC by Bryan Headley
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 11:57:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Headley 2000-11-26 17:25:33 UTC
Need clarification: compiling kernel 2.4.0-test11 fails constantly. Error
diagnostic from "as" (ignoring changed section attributes for .modinfo)
looks fairly suspicious. binutils 2.1.90 from 7.0 install disk.

Comment 1 Jakub Jelinek 2000-11-26 17:28:32 UTC
It is actually a warning (and a valid one if you look what the kernel
is doing), so the cause of failure must be something else.

Comment 2 Bryan Headley 2000-11-28 11:56:58 UTC
Could be. I know I die at ACPI loading with 2.4.0-test11ac4; pulling back the
ac4 patches, I can get the the scsi module loading, then dying with every symbol
not found. Of course the kernel built fine on 6.2. I'm dropping a line to Alan
to see if he knows what went awry in the process.


Note You need to log in before you can comment on or make changes to this bug.