Bug 213563 - xend takes 1.5 minutes to start up during boottime
xend takes 1.5 minutes to start up during boottime
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 18:53 EST by Armijn Hemel
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 17:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Armijn Hemel 2006-11-01 18:53:02 EST
Description of problem:

When I boot my machine with Xen it takes xend about roughly 95 seconds to start.

Version-Release number of selected component (if applicable):

xen-3.0.3-0.1.rc3

How reproducible:

Always


Steps to Reproduce:
1. install all xen stuff in fc6
2. boot
3.
  
Actual results:

xend takes 1.5 minutes to start.

Expected results:

Faster boot time, and/or better progress information

Additional info:

So, I don't know if this is actually a bug, or expected behaviour. All I can say
is that it takes a looong time to load.
Comment 1 Stephen Tweedie 2006-11-02 11:17:38 EST
xend starts in a few seconds for me.

What's your networking configuration?  I suspect it's getting stuck somewhere in
setting up the network; does xen networking look OK after it does finally start?
Comment 2 Armijn Hemel 2006-11-02 11:47:51 EST
There is one DHCP server (FreeBSD with ISC dhcpd), devices get DHCP leases from
that. Sometimes I use wireless, sometimes I use wired networking. Networking
seems to be just fine afterwards. Could it be the network devices that timeout?
Comment 3 Stephen Tweedie 2006-11-02 12:03:25 EST
Yes, could be; alt-sysrq-t ought to be able to show if it's hanging in dhcpcd or
somewhere similar.
Comment 4 Armijn Hemel 2006-11-05 13:03:45 EST
When I connect the network cable and everything all works fine. Only when I have
it disconnected it takes that long. So, it is not an error and therefore this
bug can be closed. I'm wondering if the start scripts for xend could benefit
from the fact that the networking script has already determined a few seconds
earlier that there is nothing on my wired interface. Or is that impossible to do?
Comment 5 Stephen Tweedie 2006-11-06 17:06:34 EST
Not impossible; but _lots_ of networking bits and pieces are likely to function
badly without any networking enabled.  Handling it more gracefully is probably
not actually a Xen problem, more that ifup itself might handle it more rapidly.

Note You need to log in before you can comment on or make changes to this bug.