Bug 213581 - qiv-2.0-6 crashes
qiv-2.0-6 crashes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qiv (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 22:00 EST by jlbartos
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 21:04:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlbartos 2006-11-01 22:00:37 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start qiv from commandline: qiv image.jpg
2.
3.
  
Actual results:
Display window appears for an instant, then goes away

Expected results:
Able to view image.

Additional info:
gtk+-1.2.10-55.fc6
imlib-1.9.13-30.fc6
glib-1.2.10-23.fc6

commandline error:
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 115 error_code 8 request_code 2 minor_code 0
Comment 1 Miha Tomsic 2006-11-02 01:00:25 EST
I can confirm that I got the same error on three machines with FC6 (one upgraded
from FC4, one upgraded from FC5 and one freshly installed). 

The strange thing is the error doesn't appear on the first machine any more. All
I did different in respect to the other two machines is that I did some package
installation and removal and some AIGLX fiddling. And qiv now again displays any
passed image on this machine.

The other two still give me the same error and no image.
Comment 2 Ville Skyttä 2006-11-06 16:06:03 EST
Workaround:

    env XLIB_SKIP_ARGB_VISUALS=1 qiv foo.jpeg

More info: bug 213172, xmms >= 1.2.10-29 in CVS and soon in the repo
Comment 3 Andreas Bierfert 2006-11-06 21:04:36 EST
Thanks for the pointer Ville :) Fixed an pushed.

Note You need to log in before you can comment on or make changes to this bug.