Bug 213599 - Broken rendering for hi_IN locale (possibly for all indic locales) in firefox 2.x
Broken rendering for hi_IN locale (possibly for all indic locales) in firefox...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 02:50 EST by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 12:43:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Bug (22.40 KB, image/png)
2006-11-02 02:50 EST, Mayank Jain
no flags Details
Test case (16 bytes, text/plain)
2006-11-02 02:51 EST, Mayank Jain
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 358276 None None None Never

  None (edit)
Description Mayank Jain 2006-11-02 02:50:41 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1)
Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1)
Gecko/20061010 Firefox/2.0

Dependent vowel gets placed at wrong position. Test case is attached, please
use it with gedit as reference rendering

Reproducible: Always

Steps to Reproduce:
1. Open firefox 2.0 & focus any text input widget
2. Open test case in gedit & copy-paste the contents in firefox's text widget
3. compare the results

OR

1. install m17n-db-hindi, scim, scim-m17n, m17n packages
2. focus any text widget in firefox and activate hi-phonetic keymap
3. press "vivek" on the keyboard in firefox & then in gedit & compare the two.

Actual Results:  
Broken rendering - since this can be reproduced with just copy-pasting text
from gedit, this is confirmed a rendering bug!

Expected Results:  
Reference results are as rendering is done in gedit

I dont have enough knowledge on other indic locales, but i suspect rendering
for others might be broken too.

I'm using pango version - pango-1.15.0-1.fc7
Comment 1 Mayank Jain 2006-11-02 02:50:41 EST
Created attachment 140093 [details]
Bug
Comment 2 Mayank Jain 2006-11-02 02:51:53 EST
Created attachment 140094 [details]
Test case
Comment 3 Christopher Aillon 2006-11-02 12:43:11 EST
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1)
Gecko/20061010 Firefox/2.0

This is an upstream User Agent string, not a Fedora one, and is not the official
2.0 User Agent, it was only a beta.  Upstream does not enable pango.

Resolving WONTFIX.  If you see this problem in Fedora builds (which enable
pango) then re-open.
Comment 4 Mayank Jain 2006-11-03 02:39:45 EST
Yup, our FC builds dont have this bug.
Thanks for having a look :)

Note You need to log in before you can comment on or make changes to this bug.