Bug 21361 - up2date -u crashes in batchRun
up2date -u crashes in batchRun
Status: CLOSED DUPLICATE of bug 19528
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-26 16:37 EST by Geoff Keating
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-26 16:37:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Keating 2000-11-26 16:37:44 EST
I ran up2date on my machine in CLI mode and got:

[geoffk@thief geoffk]$ DISPLAY= s up2date -u    

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
100.0%
Getting headers for skipped packages...
100.0%
Testing package set / solving RPM inter-dependencies...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 394, in ?
    main()
  File "/usr/sbin/up2date", line 377, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 204, in batchRun
    for index in range(updated):
TypeError: illegal argument type for built-in operation


The list of packages it wanted to install was:

[geoffk@thief geoffk]$ DISPLAY= s up2date -l

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
100.0%
Getting headers for skipped packages...
100.0%
Name                                    Version        Release
--------------------------------------------------------------
ncurses                                 5.2            2                   
modutils                                2.3.21         1                   
auth_ldap                               1.4.5          1                   
ghostscript                             5.50           8                   
glibc-devel                             2.2            5                   
glibc-profile                           2.2            5                   
joe                                     2.8            43                  
mod_dav                                 1.0.2          2                   
mod_perl                                1.24           6                   
ncurses-devel                           5.2            2                   
netscape-common                         4.76           1                   
netscape-communicator                   4.76           1                   
netscape-navigator                      4.76           1                   
nscd                                    2.2            5                   
openssh                                 2.3.0p1        4                   
openssh-askpass                         2.3.0p1        4                   
openssh-askpass-gnome                   2.3.0p1        4                   
openssh-server                          2.3.0p1        4                   

The following Packages were marked to be skipped by your configuration:


Name                                    Version        Release
--------------------------------------------------------------
glibc                                   2.2          5                   
openssh-clients                         2.3.0p1        4                   

When I installed all the openssh packages manually, up2date -u worked
again.
Comment 1 Preston Brown 2000-11-28 15:07:27 EST

*** This bug has been marked as a duplicate of 19528 ***

Note You need to log in before you can comment on or make changes to this bug.