Bug 213614 (virtnonpae) - Can't boot after selecting Xen installation (Virtualization) on non-compliant processors
Summary: Can't boot after selecting Xen installation (Virtualization) on non-compliant...
Status: CLOSED RAWHIDE
Alias: virtnonpae
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 213615 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 10:40 UTC by Jack
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 19:27:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack 2006-11-02 10:40:13 UTC
Description of problem:
The latest version of Xen now requires the presence of a 'pae' 
or 'vmx'/'svm'capable processor 
(http://fedoraproject.org/wiki/FedoraXenQuickstartFC6#head-
712c355cbc215744acb585bb1e26bd781f0376ee).  Enabling 'Virtualization' during 
installation on a platform without this support results in a unusable system 
(kernel panic at first re-boot).  

Version-Release number of selected component (if applicable):


How reproducible:
Always (?)

Steps to Reproduce:
1.Attempt fresh install with 'Virtualization' enabled (anaconda) onto a non-
compliant platform
2.perform first reboot
3.
  
Actual results:
non-operational system

Expected results:
(?) A working system without a virtualization (Xen) enabled kernel


Additional info:
There are several options for this:
1.) Virtualization support should be disabled on non-complaint processors
2.) Issue a warning message when Virtualization  selected on non-complaint 
porcessors
3.) Also install non-virtualized kernel on non-compliant platforms (including 
grub/lilo support)

Comment 1 Jack 2006-11-02 10:46:11 UTC
*** Bug 213615 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2006-11-03 19:27:12 UTC
This is a side effect of a late change to FC6 that broke the saftey net I had in
place to keep this from happening.  It's been fixed in CVS and won't be a
problem in the future.


Note You need to log in before you can comment on or make changes to this bug.