Bug 213615 - Can't boot after selecting Xen installation (Virtualization) on non-compliant processors
Can't boot after selecting Xen installation (Virtualization) on non-compliant...
Status: CLOSED DUPLICATE of bug 213614
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-11-02 05:41 EST by Jack
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-02 05:46:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jack 2006-11-02 05:41:34 EST
Description of problem:
The latest version of Xen now requires the presence of a 'pae' 
or 'vmx'/'svm'capable processor 
712c355cbc215744acb585bb1e26bd781f0376ee).  Enabling 'Virtualization' during 
installation on a platform without this support results in a unusable system 
(kernel panic at first re-boot).  

Version-Release number of selected component (if applicable):

How reproducible:
Always (?)

Steps to Reproduce:
1.Attempt fresh install with 'Virtualization' enabled (anaconda) onto a non-
compliant platform
2.perform first reboot
Actual results:
non-operational system

Expected results:
(?) A working system without a virtualization (Xen) enabled kernel

Additional info:
There are several options for this:
1.) Virtualization support should be disabled on non-complaint processors
2.) Issue a warning message when Virtualization  selected on non-complaint 
3.) Also install non-virtualized kernel on non-compliant platforms (including 
grub/lilo support)
Comment 1 Jack 2006-11-02 05:46:09 EST

*** This bug has been marked as a duplicate of 213614 ***

Note You need to log in before you can comment on or make changes to this bug.