Bug 213619 - Can't unpack LZH compressed data
Can't unpack LZH compressed data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gzip (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 05:57 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0502
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 08:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
few.R.Z (192.36 KB, application/octet-stream)
2006-11-02 05:58 EST, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2006-11-02 05:57:59 EST
gzip-1.3.3-16.rhel4

This is a regression from gzip-1.3.3-15.rhel4 caused by the fixes from bug 204676

$ gunzip few.R.Z
gunzip: few.R.Z: Bad table (case b)

$ file few.R.Z
few.R.Z: SCO compress -H (LZH) data
Comment 1 Bastien Nocera 2006-11-02 05:58:00 EST
Created attachment 140101 [details]
few.R.Z
Comment 2 Ivana Varekova 2006-11-02 10:04:59 EST
Could you please attach the source file from which the compress file few.R.Z was
created and could you describe the type of compression which was used.
Comment 3 Joern Gaertner 2006-11-02 10:43:26 EST
They used compress -H on SCO OS5.
Further details will follow. I have to wait for the customer.
Comment 5 Ivana Varekova 2006-11-09 10:36:43 EST
Could you please attach original (noncompressed) file, from which the attached
compressed file (comment 2) was created. 
Comment 7 Ivana Varekova 2006-11-13 07:09:26 EST
Thanks.
The test package which fixes this problem are on
http://people.redhat.com/varekova/gzip-1.3.3-16.rhel4.test.i386.rpm
and 
http://people.redhat.com/varekova/gzip-1.3.3-16.rhel4.test.src.rpm.
Comment 9 Ivana Varekova 2006-12-04 05:07:20 EST
The package was rebuild the link in comment 7 now contains package which is right. 
Comment 11 RHEL Product and Program Management 2006-12-12 11:53:01 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 18 Red Hat Bugzilla 2007-06-27 08:36:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0502.html

Note You need to log in before you can comment on or make changes to this bug.