Bug 213623 - Proposal: add --downloaddir option for downloadonly plugin
Proposal: add --downloaddir option for downloadonly plugin
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 06:38 EST by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 05:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed new full plugin sourrce. (830 bytes, text/plain)
2006-11-02 06:39 EST, Dmitry Butskoy
no flags Details

  None (edit)
Description Dmitry Butskoy 2006-11-02 06:38:02 EST
The yum-downloadonly plugin is very useful, especially in production
environment, when automatic updates is not a good idea. But using
"--downloadonly" option, the packages are stored in some "special", "too deep",
per-repo subdirectories (i.e. /var/cache/yum/core/packages/ for Core,
/var/cache/yum/extras/packages/ for Extras etc.) It is not very convenient indeed.

I propose to add "--downloaddir=DIR" option to this plugin, which allows to
store  packages in the specified place instead, i.e.:
"yum -y --downloadonly --downloaddir=/var/spool/update update"

We already use such a modified plugin for a long time (invoke yum from cron each
night).

P.S. Please, add it for FC5 too.
Comment 1 Dmitry Butskoy 2006-11-02 06:39:40 EST
Created attachment 140107 [details]
Proposed new full plugin sourrce.

Just full new source (the changes are trivial...)
Comment 2 Dmitry Butskoy 2006-12-15 09:21:11 EST
ping?...
Comment 3 Tim Lauridsen 2007-02-14 05:07:16 EST
Thanks for your contribution.

I have added your changes to the upstream CVS.
I will be available in the next yum-utils releases for FC6 & FC7/Rawhide.

It will not be available for FC5, because there is now special upstream branch
for  yum 2.6(FC5).
Comment 4 Dmitry Butskoy 2007-02-14 07:53:45 EST
> I have added your changes to the upstream CVS.

Where I can look at it?
I've not found it at
http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum-utils/plugins/downloadonly/
...
Comment 5 Dmitry Butskoy 2007-02-16 07:57:29 EST
OK, looks fine now.

Note You need to log in before you can comment on or make changes to this bug.