Bug 213628 - When package add fails, if item is then unchecked, pirut still tries to install it's dependencies
When package add fails, if item is then unchecked, pirut still tries to insta...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 07:00 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: pirut-1.2.8-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 06:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-11-02 07:00:06 EST
Description of problem:
Unselecting a package of which install failed is not internally registered, and
pup still tries to install it.

Version-Release number of selected component (if applicable):
pirut-1.2.5-1

How reproducible:
Yes, finally worked out the steps to repeat.

Steps to Reproduce:
1. make it impossible for pirut to get the prerequisite lm_sensors {simulating
some real world network mirror problem}
2. pirut|list|gkr
3. select gkrellm|apply|continue
4. Error downloading headers {failed to retrieve
Fedora/RPMS/lm_sensors-2.10.0-3.1.i386.rpm from core
error was [Errno 4] IOError: <urlopen error unknown url type: media>}
5. uncheck gkrellm|check aalib|apply|continue|
  
Actual results:
Error downloading headers {failed to retrieve
Fedora/RPMS/lm_sensors-2.10.0-3.1.i386.rpm from core
error was [Errno 4] IOError: <urlopen error unknown url type: media>

Expected results:
Since gkrellm {which required lm_sensors} was unselected, pirate should not be
trying to install lm_sensors.

Additional info:
This issue existed in FC5, but I had been unable to determine exactly what
causes it until now. Enjoy working that one out ;)
Comment 1 Jeremy Katz 2006-11-06 13:16:22 EST
Thanks for the extremely detailed reproducer.  Fixed in CVS and will go out at
least as an FC6 update in the near term
Comment 2 Fedora Update System 2006-11-06 15:38:38 EST
pirut-1.2.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 David Timms 2006-11-06 23:53:41 EST
In pirut-1.2.7-1.fc6, the error message produced is slightly different {but my
method of causing the inability to get the requires is also different - can't
remember what the cause was the first time}.

Here is a slightly different way to reproduce {but with a different error message}:
/etc/yum.repos.d/fedora-core.repo:
enabled=0

# pirut|list|gkr
# select gkrellm|apply|continue
Error resolving dependencies
Unable to resolve dependencies for some packages selected for installation
Missing Dependency: libsensors.so.3 is needed by package gkrellm

# uncheck gkrellm|check zsplit|apply|continue|
Error resolving dependencies
Unable to resolve dependencies for some packages selected for installation
Requiring package gkrellm-2.2.9-10.fc6 not in transaction set nor in rpmdb
---
This is a different message, but one that I also saw occasionally with fc5. It
suggests that the initial package is still listed as causing a requires, but
instead of trying to install the requires, it "notices" that something is not
quite right.
Comment 4 Jeremy Katz 2006-11-08 10:05:12 EST
I can't reproduce this behavior :/

I'll try some more later
Comment 5 Fedora Update System 2006-11-10 13:21:08 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 David Timms 2006-11-12 06:34:46 EST
OK, with version from comment #5, I can no longer repeat this error=Solved :. QED
Comment 7 Fedora Update System 2006-11-16 18:13:15 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.