Bug 213633 - Need changes in Assamese Inscript layout
Need changes in Assamese Inscript layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
: i18n
Depends On:
Blocks: 213840
  Show dependency treegraph
 
Reported: 2006-11-02 07:23 EST by Amitakhya Phukan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 07:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed as-inscript.mim file (4.89 KB, text/plain)
2006-11-03 06:06 EST, Mayank Jain
no flags Details

  None (edit)
Description Amitakhya Phukan 2006-11-02 07:23:08 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login to Assamese language session and select Inscript as the input keyboard
layout.
2. The inscript layout, according to tdil.mit.gov.in, has some Assamese special
characters allocated to %, ^, &   and *.
3. These Assamese characters are not dispalyed.
  
Actual results:
The Assamese characters allocated to the above mentioned keys are not displayed.

Expected results:
The Assamese characters should be displayed.

Additional info:
The detailed layout for Assamese Inscript can be found at: 

http://www.tdil.mit.gov.in/isciichart.pdf
Comment 1 Mayank Jain 2006-11-02 07:32:54 EST
Hi Amit,

Can you please give the unicode values to write the assamese counterparts for
these characters?

Also, I'd really appreciate an updated key summary (thanks for the original key
summary) for the new addidions in as-inscript keymap.

Thanks,
Mayank
Comment 2 Amitakhya Phukan 2006-11-02 08:53:14 EST
mayank, these characters are not single code points and hence they are not in
unicode charts. these characters are frequently occuring conjuncts.

the unicode for them are :

character for %  U+099C U+09CD U+099E
character for ^  U+09A4 U+09CD U+09F0
character for &  U+0995 U+09CD U+09B7
character for *  U+09B6 U+09CD U+09F0

I would like to emphasise that since these characters appear in the original
Inscript layout, they *should not* be removed from the Assamese keyboard layout.
These are som special characters and hence should be preserved in the keyboard
layout as was in the original form.
Comment 3 Amitakhya Phukan 2006-11-02 08:58:21 EST
There are also two characters that were present in # and $. These were the
combinations of  U+09CD U+09F0 for # and U+09F0 U+09CD for $. These characters
are also removed. These two are the much needed 'ref' forms and hence I would
also request them to be included. For details regarding the shapes of these
characters, please refer to the url i mentioned earlier while reporting this bug.
Comment 4 Mayank Jain 2006-11-03 04:07:42 EST
Amit,

Can you please also attach the updated key summary?

Thanks,
Mayank
Comment 5 Mayank Jain 2006-11-03 06:06:12 EST
Created attachment 140231 [details]
Fixed as-inscript.mim file

Thanks Amit for all the hard work :)

-- attached fixed as-inscript.mim on behalf of Amit
Comment 6 Amitakhya Phukan 2006-11-03 07:11:10 EST
The original Inscript Layout as given by tdil.mit.gov.in, has some appropriate
"Glyphs" that were assigned to "#" and "$" (See comment #3). But the present
Inscript layout doesn't have them. The patch that has been submitted also
doesn't contain these glyphs, instead I have typed the character combinations
for them. I would therefore like to know if the original Inscript layout is
available so that the glyphs can be put at the appropriate places. The Unicode
combinations for these character combinations are mentioned in comment #3. Is it
possible to get the older version of the Inscript layout  before the
modifications were made?
Comment 7 Amitakhya Phukan 2006-11-06 01:31:53 EST
i tried adding the unicode combinations in the as-inscript.mim file and then
doing a scim restart and then gdm-restart. but after that, when i try to get the
scim activated and then select as-inscript, scim crashes.i have to replace the
combinations, do a restart for scim and gdm, then as-inscript works well.
Comment 8 Mayank Jain 2006-11-06 02:32:53 EST
Was fixed in m17n-db-1_3_3-35_fc7
Comment 9 Mayank Jain 2006-11-06 03:05:59 EST
Update pushed in m17n-db-1.3.3-33.fc6
Comment 10 A S Alam 2007-03-15 07:57:07 EDT
bug is fixed, tested with following Package:
m17n-db-1.3.4-7.fc7

Note You need to log in before you can comment on or make changes to this bug.