Bug 213639 - [enh] pup - make search as you type work
[enh] pup - make search as you type work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 07:58 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 14:27:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-11-02 07:58:00 EST
Description of enhancement:
Typing in pup's updated packages list should find the closest match.

Version-Release number of selected component (if applicable):
pirut-1.2.5-1

How reproducible:
Yes.

Steps to Reproduce:
1. pup
2. type first few letters of any listed package.
  
Actual results:
The normal little text field opens in the bottom right of the list window, and
characters you enter are shown. The list is not scrolled to the matching name.

Expected results:
The list should be enhancd to scroll to the matching name.

Additional info:
I imagine the problem comes about because the text within the box always begins
with the text "{Updated} xyz packages available".

Given that:
- window title=Package Updater
- dialog title=Package Updater
- list heading=Updates Available
- each entry in the list begins with Updated,
I would consider the leading "Updated" on each item in the list is redundant.
I think removing "Updated" would make the search in list work automatically.

The "Updated" text could be removed or re-arranged thus:
- beagle package update is available
- beagle package updates available

Hopefully there wouldn't be translation problems with such a change.
Comment 1 Jeremy Katz 2006-11-03 14:33:03 EST
Rearranging the text doesn't really help with translations, though -- the right
thing to do is to use a custom search function for the tree view; this is
already done in pirut/PackageList.py and should be a pretty quick patch (search
for set_search_equal_func). 
Comment 2 Jeremy Katz 2006-11-06 14:27:58 EST
Fixed
Comment 3 Fedora Update System 2006-11-06 15:38:43 EST
pirut-1.2.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 David Timms 2006-11-07 01:05:32 EST
I confirm that pirut-1.2.7-1.fc6 {fedora-updates-testing} properly implements
the search function {along with other good additions - actual update details and
un/select all packages}.
Comment 5 Fedora Update System 2006-11-10 13:21:36 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-11-16 18:13:38 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.