Bug 213691 - system-config-soundcard gui doesn't parse model/vendor correctly
Summary: system-config-soundcard gui doesn't parse model/vendor correctly
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 16:33 UTC by Eric Sandeen
Modified: 2008-02-22 10:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 10:38:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsound.log (47.82 KB, text/plain)
2006-11-02 16:33 UTC, Eric Sandeen
no flags Details
window-shot of 2nd tab (34.53 KB, image/png)
2006-11-02 16:34 UTC, Eric Sandeen
no flags Details

Description Eric Sandeen 2006-11-02 16:33:48 UTC
system-config-soundcard-1.2.17-6

I have 2 sound cards in my machine, one pci:

[root@neon ~]# lspci | grep Audio
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) A
C'97 Audio Controller (rev 02)

and one usb:

[root@neon ~]# grep -i "imic\|griffin" /proc/bus/usb/devices
S:  Manufacturer=Griffin Technology, Inc
S:  Product=iMic USB audio system

these don't seem to be parsed right in scs.  The two tabs show up as:

Vendor: Intel
Model: Corporation 82801EB/ER ....

and 

Vendor: Griffin
Model: Technology, Inc iMic USB audio system

the tab labels also reflect these shortened vendor namess (which may be a good
thing)

Comment 1 Eric Sandeen 2006-11-02 16:33:48 UTC
Created attachment 140148 [details]
scsound.log

Comment 2 Eric Sandeen 2006-11-02 16:34:58 UTC
Created attachment 140149 [details]
window-shot of 2nd tab

Comment 3 Martin Stransky 2006-11-02 17:36:35 UTC
It should be fixed in FC6. Could you check it?

Comment 4 Eric Sandeen 2006-11-02 17:45:07 UTC
Thanks Martin, sorry for reporting an old bug.  I'll get my workstation upgraded
at some point and let you know.  (looks like dependency fun to try to install
newer scs on FC5)

Comment 5 Martin Stransky 2006-11-03 08:04:02 UTC
Don't worry about dependencies, scs from FC6 works fine under FC5 so you don't
have to reinstall all ;-) Just install it with --nodeps.

Comment 6 Eric Sandeen 2007-09-09 03:46:37 UTC
Martin, sorry for the delay here... playing with F8, I still get similar results.

On a similar box, I get two tabs, named "Intel" and "Audio"

The first is from:

[root@newbox ~]# lspci | grep -i audio
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)

and says:

Vendor: Intel
Model: Corporation 82801.....

and the other is from this usb device:

T:  Bus=03 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0d8c ProdID=0001 Rev= 0.10
S:  Manufacturer=C-Media INC.
S:  Product=USB Audio
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:* If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
I:  If#= 1 Alt= 1 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
E:  Ad=06(O) Atr=09(Isoc) MxPS= 192 Ivl=1ms

and says:

Card: Audio
Model: C-Media INC. USB Audio



Comment 7 Eric Sandeen 2007-09-10 02:01:34 UTC
Now I am confused.  I updated to latest devel bits, and it looks ok.  But the
system-config-soundcard package wasn't updated - and I'm running the original
kernel from before, as well.  Now everything seems to be parsed correctly.   I
have no idea what might have changed here...!

Comment 8 Martin Stransky 2008-02-22 10:38:23 UTC
Unfortunately s-c-s was removed from F9 and it's not going to be developed.
Closing as wontfix.


Note You need to log in before you can comment on or make changes to this bug.