Bug 213706 - Evolution/Exchange no sub-folders displayed
Summary: Evolution/Exchange no sub-folders displayed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
: 214776 214777 215681 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 17:20 UTC by Michael Colligan
Modified: 2007-11-30 22:11 UTC (History)
13 users (show)

Fixed In Version: evolution-data-server-1.8.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 14:58:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch borrowed from Debian that fixes the missing subfolders (748 bytes, patch)
2006-11-03 17:13 UTC, Sam Sharpe
no flags Details | Diff
evolution-data-server SPEC file patch to include evolution-exchange-restore-folders.patch (751 bytes, patch)
2006-11-16 23:24 UTC, Ryan Ordway
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 360593 None None None Never

Description Michael Colligan 2006-11-02 17:20:19 UTC
Description of problem:

Evolution fails to show sub-folders on Exchange server.

Version-Release number of selected component (if applicable):

FC6 completely up-to-date with:

evolution-data-server-1.8.1-1.fc6
evolution-2.8.1.1-3.fc6
evolution-webcal-2.7.1-6
beagle-evolution-0.2.10-5.fc6
evolution-connector-2.8.1-1.fc6
evolution-sharp-0.11.1-10.fc6
evolution-data-server-devel-1.8.1-1.fc6


How reproducible:

Always.  Never shows sub-folders.

Steps to Reproduce:
1.  Run evolution and connect to Exchange server with sub-folders.
2.
3.
  
Actual results:

No subfolders displayed.

Expected results:

sub-folders displayed.

Additional info:

Here's a link to the Ubuntu bug:

https://launchpad.net/distros/ubuntu/+source/evolution-data-server/+bug/63797

and here is Gnome's:

http://bugzilla.gnome.org/show_bug.cgi?id=360593

Comment 1 bastiaan 2006-11-02 23:02:37 UTC
I'm seeing the same behvaviour. For what it's worth, the gnome bug report
mentions a workaround: toggling between offline and online mode may help in
gettting to see the subfolders again. But evolution may fail in new, mysterious
ways as well....



Comment 2 bastiaan 2006-11-02 23:02:55 UTC
I'm seeing the same behvaviour. For what it's worth, the gnome bug report
mentions a workaround: toggling between offline and online mode may help in
gettting to see the subfolders again. But evolution may fail in new, mysterious
ways as well....

Comment 3 Michael Colligan 2006-11-03 05:45:14 UTC
(In reply to comment #1)
The "workaround" works for me as well but... probably not how the functional
requirements were written.

Comment 4 Sam Sharpe 2006-11-03 14:47:12 UTC
The workaround does not work for me :o(

Comment 5 Sam Sharpe 2006-11-03 17:13:27 UTC
Created attachment 140281 [details]
Patch borrowed from Debian that fixes the missing subfolders

Comment 6 Sam Sharpe 2006-11-03 17:14:35 UTC
I've just rolled my own RPM (heh, by patching the source tarball not doing it
properly because it's a Friday afternoon) with the debian patch above applied,
and my folders came back... Go Me!

Comment 7 Frank Pineau 2006-11-08 20:19:32 UTC
Patch did not work for me. :(

Comment 8 Matthew Barnes 2006-11-09 15:32:26 UTC
*** Bug 214776 has been marked as a duplicate of this bug. ***

Comment 9 Matthew Barnes 2006-11-09 15:33:26 UTC
*** Bug 214777 has been marked as a duplicate of this bug. ***

Comment 10 Valent Turkovic 2006-11-10 14:41:54 UTC
The workaround doesn't work for me :(
Please make new rpms.

Thank you.

Comment 11 bastiaan 2006-11-10 16:00:00 UTC
for those having trouble to get the workaround working: like most features in
Evolution it appears to have a race condition :-( 
To win the race, in my experience the following works best:
open evolution
switch to offline
close evolution
reopen evolution
hopefully see your subfolders
switch back to online

hope this helps. Of course fixing the bug would be better... 
<comments on quality of evolution code deleted>



Comment 12 Valent Turkovic 2006-11-13 07:26:04 UTC
This still didn't do it for me.

Comment 13 Valent Turkovic 2006-11-13 07:52:33 UTC
I have installed Evolution-2.8.1.1 and the bug is still present.

Can you please confirm that 2.8.1.1 solves this bug?

Comment 14 Bojan Smojver 2006-11-13 10:25:00 UTC
Regarding comment #13, this is the version of Evolution against which the bugs
has been originally reported. So, it doesn't include the fix.

Comment 15 Matthew Barnes 2006-11-15 12:32:06 UTC
*** Bug 215681 has been marked as a duplicate of this bug. ***

Comment 16 Ryan Ordway 2006-11-16 23:24:33 UTC
Created attachment 141425 [details]
evolution-data-server SPEC file patch to include evolution-exchange-restore-folders.patch

Comment 17 Ryan Ordway 2006-11-16 23:34:51 UTC
I was experiencing this same issue with:

evolution-2.8.1.1-3.fc6
evolution-devel-2.8.1.1-3.fc6
evolution-webcal-2.7.1-6
evolution-data-server-devel-1.8.1-1
beagle-evolution-0.2.10-6.fc6
evolution-connector-2.8.1-1.fc6
evolution-data-server-1.8.1-1
evolution-sharp-0.11.1-10.fc6

I downloaded the latest SRPM for evolution-data-server,
evolution-data-server-1.8.1-1.fc6.src.rpm, applied the patch from comment #5
above, and updated the spec file as in the patch from comment #16 above. This
resolved the issue for me. 

If you need RPMs to fix this before an official update is released, I've put my
RPMs up here:

http://vodka.library.oregonstate.edu/files/evolution-data-server-1.8.1-2.i386.rpm
http://vodka.library.oregonstate.edu/files/evolution-data-server-devel-1.8.1-2.i386.rpm




Comment 18 Matthew Barnes 2006-11-17 01:18:53 UTC
Thanks for the patch!  This should land in Fedora Updates Testing shortly.

evolution-data-server-1.8.1-2.fc6

Comment 19 Earl Pomeroy 2006-11-18 07:21:34 UTC
I installed the evolution-data-server-1.8.1-2.fc6 from Fedora Updates Testing
this morning and it resolves the issue for me. All of my sub-folders are back.

Comment 20 Valent Turkovic 2006-11-19 13:53:39 UTC
The solution for me is to use Evolution 2.8 - version that shipped with Fedora
Core 6, because that one works great. Don't upgrade to 2.8.1 of 2.8.1.1

Comment 21 Bojan Smojver 2006-11-19 20:09:00 UTC
evolution-data-server-1.8.1-2.fc6 (from testing) fixes the problem here.

Comment 22 James Juran 2006-11-20 13:32:14 UTC
evolution-data-server-1.8.1-2.fc6 from testing works for me too.  Thanks!


Comment 23 Stefan Becker 2006-11-28 12:52:42 UTC
Just updated to evolution-data-server-1.8.1-2.fc6 from updates. I can definitely
see subfolders now...

As an additional benefit calendar alerts seem to work now too :-)

Comment 24 Matthew Barnes 2006-11-28 14:58:04 UTC
Closing this bug based on user feedback.  Feel free to re-open it if you find
that the problem has not been resolved.


Note You need to log in before you can comment on or make changes to this bug.