Bug 213707 - Preserve or add ::1 to /etc/hosts
Summary: Preserve or add ::1 to /etc/hosts
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 213709
TreeView+ depends on / blocked
 
Reported: 2006-11-02 17:23 UTC by David Cantrell
Modified: 2008-01-11 22:20 UTC (History)
0 users

Fixed In Version: 1.4.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 22:20:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Cantrell 2006-11-02 17:23:42 UTC
system-config-network needs to preserve the IPv6 localhost entry or add it if
missing when dealing with /etc/hosts.  In anaconda, we write out:

::1 localhost6.localdomain6 localhost6

I have not found an RFC indicating what ::1 should be called and different
operating systems are using different names.  If you find an official naming
standard for ::1, let me know so I can make the change to anaconda as well.

Comment 1 Nerijus Baliūnas 2006-11-07 03:02:46 UTC
BTW, FC6 clean install puts only line
::1   server.xxx.lt   server      localhost.localdomain   localhost
to /etc/hosts, and because of that some programs don't work. Putting a line
127.0.0.1    server.xxx.lt   server      localhost.localdomain   localhost
helps.

I unchecked ipv6 support during install. Might be some reversed logic - instead
of putting ipv4 addr only, it puts ipv6 addr only.

Comment 2 David Cantrell 2006-11-07 03:35:21 UTC
(In reply to comment #1)
> BTW, FC6 clean install puts only line
> ::1   server.xxx.lt   server      localhost.localdomain   localhost
> to /etc/hosts, and because of that some programs don't work. Putting a line
> 127.0.0.1    server.xxx.lt   server      localhost.localdomain   localhost
> helps.
> 
> I unchecked ipv6 support during install. Might be some reversed logic - instead
> of putting ipv4 addr only, it puts ipv6 addr only.

This problem is not a system-config-network problem, it's an anaconda problem. 
It's known and has been fixed in anaconda's CVS (rawhide).

Comment 3 Fedora Update System 2007-12-06 20:44:53 UTC
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'

Comment 4 Fedora Update System 2008-01-11 22:20:29 UTC
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.