Bug 213731 - KDE 3.5.5 upgrade lost a lot of content in KDE menu
KDE 3.5.5 upgrade lost a lot of content in KDE menu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 213085 213290 213445 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 14:02 EST by Scott Dowdle
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 10:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2006-11-02 14:02:48 EST
Upgrade to kdebase-3.5.5-0.1.fc6 caused a LOT to change in the KDE menu
organization.  A LOT is missing.  Specifically... all System Admin stuff is
gone... all Preferences are gone... no link to kcontrol... all of the sub-menus
that used to be in under some of the menus had disappeared.

I ran the kde menu editor but it crashed after I made some additions and tried
to save them.

This happened on FC5 as well after upgrading to the recently released KDE 3.5.5
packages.  This along with the kcontrol Desktop -> Panel control blanked out
(reported elsewhere) make for a somewhat painful KDE ugprade.

If I wasn't detailed enough, feel free to ask questions.

Perhaps it was KDE's fault by having a problem parsing 3.5.4's ~/.kde/<settings>
but I doubt it.
Comment 1 Ngo Than 2006-11-03 09:51:23 EST
could you please try following steps:

- login into KDE with your login name
- mv $HOME/.config HOME/.config.orig
- kbuildsycoca --noincremental

the menus should be ok after this action.

Comment 2 Scott Dowdle 2006-11-03 09:59:35 EST
The menus were ok after that action.  Thanks!

I also noticed it fixed the blanked out kcontrol Desktop -> Panel issue too.

Keep up the good work.
Comment 3 Ngo Than 2006-11-03 10:23:12 EST
it's a bug in the old kde version which causes this issue. The bug is now 
resolved in new kde version, but the side affect is that the user has to do 
the obove steps once to get the menu back in some cases.

Thanks for your report
Comment 4 Diego Novillo 2006-11-07 08:48:29 EST
*** Bug 213445 has been marked as a duplicate of this bug. ***
Comment 5 Ngo Than 2006-11-07 10:15:41 EST
*** Bug 213085 has been marked as a duplicate of this bug. ***
Comment 6 Ngo Than 2006-11-13 08:40:40 EST
*** Bug 213290 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.