Bug 213737 - an attempt to stop clvmd when it's already stopped will cause invalid VG errors
Summary: an attempt to stop clvmd when it's already stopped will cause invalid VG errors
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Milan Broz
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 19:16 UTC by Corey Marthaler
Modified: 2013-03-01 04:04 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0046
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 21:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0046 normal SHIPPED_LIVE lvm2-cluster bug fix update 2007-05-10 21:06:38 UTC

Description Corey Marthaler 2006-11-02 19:16:37 UTC
Description of problem:
This is a rhel4 dup of bz 211686.

Comment 2 Milan Broz 2006-11-20 21:59:19 UTC
Fixed in build lvm2-cluster-2.02.14-1.

Comment 3 Corey Marthaler 2006-11-21 21:57:42 UTC
Fix verified in lvm2-cluster-2.02.15-3.

Comment 4 Dean Jansa 2007-05-03 14:11:11 UTC
I'm still seeing each word of the error messages as a VG.

(Note, this is a bit different than the first way Corey hit this.  I'm not stopping clvmd - this is at start 
time without a cluster under it, so clvmd must fall back to local locking.)


lvm2-2.02.21-5.el4
lvm2-cluster-2.02.21-7.el4

INIT: Entering runlevel: 3
Entering non-interactive startup
  connect() failed on local socket: Connection refused
  No volume groups found
Starting monitoring for VG WARNING::   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "WARNING:" not found
[FAILED]
Starting monitoring for VG Falling:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "Falling" not found
[FAILED]
Starting monitoring for VG back:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "back" not found
[FAILED]
Starting monitoring for VG to:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "to" not found
[FAILED]
Starting monitoring for VG local:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "local" not found
[FAILED]
Starting monitoring for VG file-based:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "file-based" not found
[FAILED]
Starting monitoring for VG locking.:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "locking." not found
[FAILED]
Starting monitoring for VG Volume:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "Volume" not found
[FAILED]
Starting monitoring for VG Groups:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "Groups" not found
[FAILED]
Starting monitoring for VG with:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "with" not found
[FAILED]
Starting monitoring for VG the:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "the" not found
[FAILED]
Starting monitoring for VG clustered:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "clustered" not found
[FAILED]
Starting monitoring for VG attribute:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "attribute" not found
[FAILED]
Starting monitoring for VG will:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "will" not found
[FAILED]
Starting monitoring for VG be:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "be" not found
[FAILED]
Starting monitoring for VG inaccessible.:   connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
Volume group "inaccessible." not found
[FAILED]



Comment 5 Milan Broz 2007-05-03 17:35:41 UTC
This is seems to be bug in lvm-monitoring initscript - not clvmd one.
See "Starting monitoring for VG"...

Please could you verify it and report bug to lvm2 package (monitoring script is
in base lvm2 package) ?

I so the original bug is fixed and we need trace new one for 4.6.

Comment 7 Red Hat Bugzilla 2007-05-10 21:08:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0046.html



Note You need to log in before you can comment on or make changes to this bug.