Bug 213768 - Mounted partitions not showing up in the desktops computer panel.
Summary: Mounted partitions not showing up in the desktops computer panel.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 22:07 UTC by Mark
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 15:52:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark 2006-11-02 22:07:28 UTC
Description of problem:
i`ve mounted 2 partitions in fstab and they aren`t showing up un the computer
window (that window where you also have: Floppy Drive, Filesystem, CD-RW/DVD-RW
and Network)

The partitions i try to mount are 2 windows NTFS partitions and i can just
access them when i go to the folders.. so the mount itself is going fine. i
tried it with ntfs-3g and the default mount stuff but without any luck. i tried
the following mount options:

defaults
defaults,user
defaults,auto
and serveral oter  LONG options that i found on a forum somewhere.

In the gconf-editor settings the value:
apps-->nautilus-->desktop-->volumes_visible is turned on!

All this stuff is tested on Fedora Core 6 with the latest patches and updates
installed.

Any solution for this?

Comment 1 Alexander Larsson 2006-11-08 14:27:29 UTC
David, what do you have to do these days to get this to work?


Comment 2 Steve 2007-01-21 11:58:43 UTC
i've the same thing here but only on one machine (both are fc6). all
ssh-connections (mappings) are shown but no cifs!

Comment 3 Steve 2007-03-17 12:55:30 UTC
is there any solution?

Comment 4 Mark 2007-03-19 13:38:43 UTC
OMG is this still a open bug.
is this bug reporting stuff even usefull if bugs don`t get solved.

anyway i FIXED it myself
you have to delete this file:
/usr/share/hal/fdi/policy/10osvendor/99-redhat-storage-policy-fixed-drives.fdi
(if it`s not there locate "99-redhat-storage-policy-fixed-drives.fdi" it and
delete it)

i will open up a discussion about this partition stuff on the fedora-devel-list
because i seriously hope that this BUG will be gone in FC7 and as of this moment
it`s still present.

Comment 5 Steve 2007-03-19 14:36:49 UTC
this does still not work for me. i deleted that file and made a rebot. is there
any other way?

Comment 6 Gérard Milmeister 2007-03-19 15:24:47 UTC
(In reply to comment #4)
> OMG is this still a open bug.
> is this bug reporting stuff even usefull if bugs don`t get solved.
> 
> anyway i FIXED it myself
> you have to delete this file:
> /usr/share/hal/fdi/policy/10osvendor/99-redhat-storage-policy-fixed-drives.fdi
> (if it`s not there locate "99-redhat-storage-policy-fixed-drives.fdi" it and
> delete it)
This is not a bug, this behaviour is intended. Only user-mountable devices are
shown. If a filesystem is mounted fixed, it is regarded as part of the root
filesystem. You can always create a link on your desktop to access some part in
the filesystem more quickly.

Comment 7 Steve 2007-03-19 15:32:38 UTC
(In reply to comment #6)
> This is not a bug, this behaviour is intended. Only user-mountable devices are
> shown. If a filesystem is mounted fixed, it is regarded as part of the root
> filesystem. You can always create a link on your desktop to access some part in
> the filesystem more quickly.

i have many fedora's with the same, in fstab, mounted shares, but only by one
machine this happens. how can it be?



Comment 8 Steve 2007-03-19 15:40:46 UTC
here is my fstab entry:

//192.168.100.1/1   /mnt/1      cifs   
username=xxx,password=xxx,uid=user,gid=user,dir_mode=0755,file_mode=0644  0 0
//192.168.100.1/2   /mnt/2      cifs   
username=xxx,password=xxx,uid=user,gid=user,dir_mode=0755,file_mode=0644  0 0
//192.168.100.1/3   /mnt/3      cifs   
username=xxx,password=xxx,uid=user,gid=user,dir_mode=0755,file_mode=0644  0 0
//192.168.100.1/4   /mnt/4      cifs   
username=xxx,password=xxx,uid=user,gid=user,dir_mode=0777,file_mode=0777  0 0


Comment 9 David Zeuthen 2007-03-19 15:52:14 UTC
This is intended behavior.
 
markg852@hotmail.com: Please don't just reopen bugs again like that....

Comment 10 Steve 2007-03-19 16:12:18 UTC
I am stupid or what? Please read my post before!

Comment 11 David Zeuthen 2007-03-19 16:17:44 UTC
(In reply to comment #10)
> I am stupid or what? Please read my post before!

This bug is for tracking partitions from attached hard drives, not about
networked CIFS mounts; I'm unsure how gnome-vfs2 deals with that. 

I'd open a new bug about that; these are just different things.


Comment 12 Steve 2007-03-19 16:20:52 UTC
Understood, thanks!

Comment 13 David Zeuthen 2007-03-19 16:22:15 UTC
I also sent this to fedora-devel-list but it's better to have here in Bugzila

> Why is it closed and why is it not a bug if there is NO info in that
> thread on how to resolve it (except the last post i just made there)
> there isn`t even a link to a page anywhere that describes on how to
> solve it.

Because the policy right now is to only mount hotpluggable drives and
media from drives that accept removable media. Just think about security
implications if you had read/write access to the password database on a
Windows partition...


Comment 14 Mark 2007-03-20 13:51:40 UTC
(In reply to comment #9)
> This is intended behavior.
>  
> markg852@hotmail.com: Please don't just reopen bugs again like that....

i opened this bug and i seem to have closed it also (by accident) so i opened it
again.

i think that partitions should be just vissable when you want it. i`m the only
user on my pc and i simply want to see all the partitions.

Fedora is currently limiting me in that way.
and for:
>  Just think about security
> implications if you had read/write access to the password database on a
> Windows partition...

i`m the only user so i don`t realy want to be limited by those kind of things.
and atleast provide information on how to show the partitions.. cause that`s
extremely difficult to find.


Note You need to log in before you can comment on or make changes to this bug.