Bug 213770 - printing stopped working after a "yum update"; lpr: Unsupported format 'application/octet-stream'!
printing stopped working after a "yum update"; lpr: Unsupported format 'appli...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 17:11 EST by Larry Dillon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 08:51:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Larry Dillon 2006-11-02 17:11:03 EST
Description of problem:
After running a "yum update" printing stopped working

Version-Release number of selected component (if applicable):
uname -a
Linux mud.rocky.edu 2.6.18-1.2200.fc5 #1 Sat Oct 14 16:59:26 EDT 2006 i686 i686
i386 GNU/Linux

How reproducible:
any way I tried to print; even tried different queues

Steps to Reproduce:
1.lpr foo.txt
2.
3.
  
Actual results:
lpr: Unsupported format 'application/octet-stream'!

Expected results:
functional printing

Additional info:
cp /etc/cups/mime.types.rpmsave /etc/cups/mime.types fixed the problem;
etc/cups/mime.types didn't exist
Comment 1 Tim Waugh 2006-11-03 06:10:48 EST
What does 'rpm -q cups' say?
Comment 2 oll 2006-11-15 08:22:18 EST
Exactly the same problem for me.
cups-1.2.5-1.fc5.4
Comment 3 Tim Waugh 2006-11-15 08:34:38 EST
Use system-config-printer to create a new queue for 'Generic raw' on the server.
 Don't use this queue, just create it.  It does not need to be shared.  The
existence of this queue causes system-config-printer to configure CUPS so that
application/octet-stream is accepted on that server.
Comment 4 Philip Prindeville 2006-11-24 14:52:45 EST
I'm running 1.2.6-1.2.fc5 from updates-testing.

If we can't run system-config-printer (too many systems that are headless or
remotely managed... plus we configure printers at install time with a Kickstart
%post script), how do you do this from the CLI with lpadmin?

And is this a permanent change, or a transient bug that will eventually be
fixed? Will lpadmin continue to not work?

Also, why does the shipped /etc/cups/mime.types have application-stream/octet
commented out?
Comment 5 Philip Prindeville 2006-11-24 15:01:26 EST
Hmm.  Just tried:

# lpadmin -p "Generic raw" -v lpd://localhost/officejet-6200-series
lpadmin: Printer name can only contain printable characters!
# 

no joy.
Comment 6 Philip Prindeville 2006-11-24 15:04:59 EST
See also:

http://www.cups.org/str.php?L2120

according to Mike Sweet, this is a distro issue, not a release defect.
Comment 7 Tim Waugh 2006-12-01 08:51:41 EST
> And is this a permanent change

This is not a change in behaviour -- system-config-printer has always worked in
this in FC5.  It is a design defect, one that has been rectified by re-writing
the tool in FC6.

> # lpadmin -p "Generic raw" -v lpd://localhost/officejet-6200-series

You must use system-config-printer to create the raw queue. (By the way, don't
put spaces in the name of the queue.)
Comment 8 Philip Prindeville 2006-12-01 12:21:39 EST
(In reply to comment #7)
> > And is this a permanent change
> 
> This is not a change in behaviour -- system-config-printer has always worked in
> this in FC5.  It is a design defect, one that has been rectified by re-writing
> the tool in FC6.
> 
> > # lpadmin -p "Generic raw" -v lpd://localhost/officejet-6200-series
> 
> You must use system-config-printer to create the raw queue. (By the way, don't
> put spaces in the name of the queue.)


I'm not getting it:  cups and cups-lpd are the base software.  How could an
optional utility like possibly break things?
Comment 9 Philip Prindeville 2006-12-01 12:24:09 EST
Grrr.  "optional utility like system-config-printer possibly break things?"
Comment 10 Philip Prindeville 2006-12-12 19:29:06 EST
(In reply to comment #3)
> Use system-config-printer to create a new queue for 'Generic raw' on the server.
>  Don't use this queue, just create it.  It does not need to be shared.  The
> existence of this queue causes system-config-printer to configure CUPS so that
> application/octet-stream is accepted on that server.

I did this, and things are still not working.

There must be something else that needs to be done, because I'm still seeing:

Dec 12 17:28:05 mail cups-lpd[14500]: Connection from
media.redfish-solutions.com (IPv4 192.168.1.5)
Dec 12 17:28:05 mail cups-lpd[14500]: Receive print job for officejet-6200-series
Dec 12 17:28:05 mail cups-lpd[14500]: Print file - job ID = 49
Dec 12 17:28:05 mail cups-lpd[14500]: Unable to send document - Unsupported
format 'application/octet-stream'!
Dec 12 17:28:05 mail cups-lpd[14500]: Closing connection
Comment 11 Tim Waugh 2006-12-13 05:18:33 EST
Perhaps /etc/cups/mime.convs needs to have a line uncommented?
Comment 12 Philip Prindeville 2006-12-14 00:45:12 EST
(In reply to comment #11)
> Perhaps /etc/cups/mime.convs needs to have a line uncommented?

Bingo.  You have to edit both mime.types and mime.convs ...

Note You need to log in before you can comment on or make changes to this bug.