Bug 213786 - upgrade install of ssl enabled servers changes file/dir permisssions from nobody to root
upgrade install of ssl enabled servers changes file/dir permisssions from nob...
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 fds104tracking 240316
  Show dependency treegraph
 
Reported: 2006-11-02 18:25 EST by Rich Megginson
Modified: 2015-12-07 11:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:30:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (6.47 KB, patch)
2006-11-03 12:36 EST, Rich Megginson
no flags Details | Diff
cvs commit log (127 bytes, text/plain)
2006-11-03 14:11 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2006-11-02 18:25:28 EST
The setup script changes the file/directory permissions from "nobody" to "root"
and causes many errors during upgrade of fds102 to fds103 if the servers are ssl
enabled.
Comment 1 Rich Megginson 2006-11-03 12:36:01 EST
Created attachment 140290 [details]
diffs

The ssloff and sslon operations change several files, by grep/sed to temp
files, then moving the temp files over the original ones.  When done as root,
this changes the file ownership to root from the original nobody.  In order to
preserve the file/directory ownership, we first figure out the instance, then
use the ownership of that dse.ldif file to determine the server user:group.  We
have to do this before the call to SSLOff because SSLOff needs the user:group
to chown the files.  Then, every time we create a new file and replace an
existing one, we do a chown $user:$group to preserve the existing file
ownership.
Comment 2 Noriko Hosoi 2006-11-03 13:45:50 EST
Argh...  That's why the upgrade failed when SSL was on... :(
Your changes look good.  Thanks...
Comment 3 Rich Megginson 2006-11-03 14:11:55 EST
Created attachment 140304 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: The ssloff and sslon operations change several files, by
grep/sed to temp
files, then moving the temp files over the original ones.  When done as root,
this changes the file ownership to root from the original nobody.  In order to
preserve the file/directory ownership, we first figure out the instance, then
use the ownership of that dse.ldif file to determine the server user:group.  We

have to do this before the call to SSLOff because SSLOff needs the user:group
to chown the files.  Then, every time we create a new file and replace an
existing one, we do a chown $user:$group to preserve the existing file
ownership.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no

Note You need to log in before you can comment on or make changes to this bug.