Bug 213807 - [QLogic RHEL5.0B2] patch to add support for qla4032 for qla4xxx driver
[QLogic RHEL5.0B2] patch to add support for qla4032 for qla4xxx driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brian Brock
: FutureFeature
Depends On: 215641 216255
Blocks: 216985
  Show dependency treegraph
 
Reported: 2006-11-02 21:51 EST by David Somayajulu
Modified: 2009-06-19 05:46 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 07:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add support for qla4032 for qla4xxx driver (13.72 KB, patch)
2006-11-02 21:51 EST, David Somayajulu
no flags Details | Diff
rejenerated patch against root of kernel source tree (16.39 KB, patch)
2006-12-04 20:52 EST, David Somayajulu
no flags Details | Diff

  None (edit)
Description David Somayajulu 2006-11-02 21:51:59 EST
Description of problem:
Adding support for the qla4032 the next version of Qlogic iSCSI HBA for 
qla4xxx driver

Version-Release number of selected component (if applicable):
5.00.05b9-k

How reproducible:
Not applicable

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Somayajulu 2006-11-02 21:51:59 EST
Created attachment 140206 [details]
patch to add support for qla4032 for qla4xxx driver
Comment 2 Andrius Benokraitis 2006-11-03 00:08:17 EST
David, is this an entirely new card with new PCI IDs, and therefore a new entry
in mkinitrd/anaconda?

Also, is this patch upstream?
Comment 4 RHEL Product and Program Management 2006-11-03 00:25:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 6 Mike Christie 2006-11-03 13:14:36 EST
This is the patch we told them we could not merge right now because it was too
late - way past new feature deadlone. The kernel patch is not upstream.

Did qlogic assign this to the anaconda team?
Comment 8 Mike Christie 2006-11-03 13:18:16 EST
Oh yeah the patch is pretty harmless. I mean not much chance for regressions.
Comment 15 Jay Turner 2006-12-01 15:29:06 EST
This one feels way too late to me.  There's far too much code change here to
pull in this late in the cycle and too much testing (any testing with older
cards supported by this driver) would be invalidated.  QE nak.
Comment 16 Andrius Benokraitis 2006-12-01 16:26:59 EST
Action for QLogic : Our Quality Engineering group has just evaluated the
proposed patch and is very hesitant to include it for RHEL 5.0 GA for the
following reasons:

* Possible problems with the patch, per Mike Christie
* Possible regressions with older QLogic cards
* This is a feature request, and it is very very late. The patch includes more
items other than simple userspace PCI ID addtions/changes.
* Is this patch being driven more by QLogic or IBM?

Assuming the problems Mike found are resolved easily, Red Hat would like to see
an agressive test plan for the older cards. This is by far the most important
factor.

At this point the patch is not committed by all Red Hat groups for inclusion in
RHEL 5.
Comment 20 David Somayajulu 2006-12-04 20:52:52 EST
Created attachment 142793 [details]
rejenerated patch against root of kernel source tree

The problem that Mike observe was due to a bug in the ioctl module. Please use
the ioctl module at 
ftp://ftp.qlogic.com/outgoing/linux/iSCSI/qisioctl/v2.00.01.b1/

Also this patch is now dependant on the inclusion of the following patches.
Bugzilla Bug 215641: Patch to fix reset issue when ethernet interface is
enabled.
Bugzilla Bug 216255: qla4xxx: fix timing issue for nvram accesses
Comment 21 Andrius Benokraitis 2006-12-05 16:38:20 EST
David, if you don't notify (add to CC-list) Tom or me of new bugs as listed in
Comment #20, they aren't guaranteed to get on anyone's radar screens.
Comment 31 Trung V Nguyen 2006-12-15 14:58:31 EST
Trung V Nguyen - IBM System x networking/iSCSI products development
System x plans to release QLogic QLE406xC HBAs, for System x, during mid May 07
to mid June 07. RH levels supported are RHEL 4.x and 5.x.
So please add QLE406xC support to RH 5. Thanks !
Comment 32 Andrius Benokraitis 2006-12-15 15:13:08 EST
Trung, does the supplied patch add support for the QLE406xC though?
Comment 33 Andrius Benokraitis 2006-12-15 16:35:58 EST
From Dave @ QLogic:

>Yes, exactly. The ASICS is 4032 which is used on QLE406x HBA's. That is
>what the latest patches submitted are for - adding support for these
>adapters.
Comment 35 Jay Turner 2006-12-18 13:58:30 EST
QE ack for RHEL5.
Comment 36 Andrius Benokraitis 2006-12-18 16:00:54 EST
Mike, if this is in POST, does this mean the other bugs (bug 215641 and bug
216255) should also be in POST as they are dependent bugs?
Comment 37 Mike Christie 2006-12-18 16:34:11 EST
I think post is for when patches are posted. I sent the orignal patch before
qlogic rerolled the patches and made this patch dependent on other ones.

I am in the middle of sorting out all the patches and trying to make something
that applies.
Comment 38 David Somayajulu 2006-12-18 19:39:00 EST
That is correct. you need 215641 and 216255 are need as well.
Comment 39 Don Zickus 2007-01-02 20:12:52 EST
in 2.6.18-1.2943.el5
Comment 40 Jay Turner 2007-01-23 07:03:34 EST
Patch confirmed in 2.6.18-4.el5.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.