Bug 213809 - Setup of tog-pegasus SDK fails rhel5 beta2
Setup of tog-pegasus SDK fails rhel5 beta2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 22:04 EST by Warren Otsuka
Modified: 2010-10-22 02:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:37:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Otsuka 2006-11-02 22:04:12 EST
Description of problem:
The setup make of the tog-pegasus samples fails with the following error:
gmake[1]: Entering directory `/usr/share/Pegasus/samples/Providers/Load'
+++++ Creating root/SampleProvider namespace ...
+++++ Loading CIM_Core into root/SampleProvider namespace ...
Error: CIM_ERR_FAILED: A general error occurred that is not covered by a more 
specific error code: "cannot create 
directory: /var/lib/Pegasus/repository/root#SampleProvider"
Failed to set DefaultNamespacePath.
gmake[1]: *** [createrepository] Error 247

The entry in /var/log/audit/audit.log:
type=AVC msg=audit(1162487001.576:561): avc:  denied  { create } for  
pid=11458 comm="cimserver" name="root#SampleProvider" 
scontext=root:system_r:pegasus_t:s0 tcontext=root:object_r:pegasus_data_t:s0 
tclass=dir



Version-Release number of selected component (if applicable):
tog-pegasus-devel-2.5.2-2.fc6.ia64.rpm


How reproducible:
Always

Steps to Reproduce:
1.rpm -ih tog-pegasus-devel-2.5.2-2.fc6.ia64.rpm
2.cd /usr/share/Pegasus/samples
3.make
4.make setupSDK

  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Otsuka 2006-11-02 22:18:24 EST
Works on x86_64.
Comment 2 RHEL Product and Program Management 2006-11-06 11:00:56 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Tim Potter 2007-02-01 20:26:16 EST
Bug is still present in rhel5-rc1.
Comment 6 Pete Graner 2007-05-02 08:00:51 EDT
Should be cleared by rebasing this package in 5.1, ACKing and leaving as
tracker, once verified should be closed.
Comment 11 Denise Eckstein 2007-08-08 15:48:12 EDT
I've reproduced this problem on RHEL5.1 Beta 1 on an ia64 platform using tog-
pegasus-devel-2.6.0-4.el5.  Note: Fixes for Bugs 250710 and 251409 are 
required prior to getting to this error.
Comment 12 Radek Vokal 2007-08-14 08:05:03 EDT
*** Bug 250710 has been marked as a duplicate of this bug. ***
Comment 13 John Poelstra 2007-08-27 14:18:04 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 14 Denise Eckstein 2007-08-30 01:00:15 EDT
I'm still seeing this problem after installing RHEL5.1 Snapshot 3 on a ia64 
plaform using tog-pegasus-devel-2.6.0-6.el5. On failure, the following entry 
was added to syslog.

Aug 29 21:40:15 biscayne setroubleshoot:      SELinux is 
preventing /usr/sbin/cimserver (pegasus_t) "create" access to 
SDKExamples#DefaultCXX (pegasus_data_t).      For complete SELinux messages. 
run sealert -l 2acaf448-edd0-40aa-9cc0-be56abb2ea63

The cimserver is attempting to create the 
directory /var/lib/Pegasus/repository/SDKExamples#DefaultCXX.

Just a reminder, we are not seeing this failure on x86_64.

Is there some way for me to verify that I've correctly installed the package 
the contains the fix?

Thanks,
Denise

Comment 15 John Poelstra 2007-08-30 09:25:38 EDT
Changing to FAILS_QA based on comment #14

At a glance I wonder if this looks like a SELinux policy problem, but it seems
strange that it does not occur on x86_64
Comment 16 Jay Turner 2007-08-30 09:44:46 EDT
Moving to Assigned.
Comment 17 Daniel Walsh 2007-09-01 07:08:10 EDT
Fixed in selinux-policy-2.4.6-88
Comment 18 Vitezslav Crhonek 2007-09-03 05:58:34 EDT
Change component from tog-pegasus to selinux-policy.
Comment 21 John Poelstra 2007-09-11 15:22:49 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot6 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 22 Denise Eckstein 2007-09-13 01:35:22 EDT
Verified that problem has been fixed in RHEL4.1-Snapshot6.

Thanks!
Denise
Comment 25 errata-xmlrpc 2007-11-07 11:37:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html

Note You need to log in before you can comment on or make changes to this bug.