Bug 213818 - Crash in anaconda.backend.doPreInstall
Crash in anaconda.backend.doPreInstall
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 00:50 EST by Ed Swierk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 16:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2006-11-03 00:50:56 EST
Using Anaconda to upgrade an FC5 system to FC6, it crashes after I click Next in
the final confirmation dialog before installation begins.  This is the only part
of the traceback I could capture:

21:28:50 INFO    : moving (1) to step confirmupgrade
21:29:39 INFO    : moving (1) to step install
21:29:39 INFO    : moving (1) to step migratefilesystems
21:29:39 INFO    : moving (1) to step preinstallconfig
21:29:40 INFO    : could not create directory /var/lib: File exists
21:29:40 WARNING : no dev package, going to bind mount /dev
21:29:40 CRITICAL: Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 1240, in doPreInstall
    f.close()
  File "/usr/lib/anaconda/backend.py", line 157, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 923, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 243, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 950, in handleRenderCallback
    self.currentWindow.renderCallback()
IOError: [Errno 22] Invalid argument
Comment 1 Ed Swierk 2006-11-03 01:10:13 EST
The crash occurred because I had replaced /etc/mtab with a symlink to /proc/mounts.

Adding os.unlink(anaconda.rootPath + "/etc/mtab") immediately after the "An old
mtab can cause confusion" comment in yuminstall.py would avoid the crash.
Comment 2 Chris Lumens 2007-02-22 16:14:02 EST
This will be fixed in the next build of anaconda.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.