Bug 213873 - intel driver failure in FC6
intel driver failure in FC6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 10:43 EST by david schuller
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 18:36:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file (46.29 KB, text/plain)
2006-11-03 10:43 EST, david schuller
no flags Details
X config file (1.01 KB, application/octet-stream)
2006-11-03 10:44 EST, david schuller
no flags Details
output from dmesg (15.60 KB, application/octet-stream)
2006-11-03 10:46 EST, david schuller
no flags Details
X log file from startx (46.29 KB, text/plain)
2006-11-03 16:09 EST, david schuller
no flags Details
Xorg.0.log with intel driver and i386 distribution of FC6 (47.81 KB, text/plain)
2006-11-06 17:36 EST, david schuller
no flags Details
My current xorg.conf file, with MonitorLayout, etc (939 bytes, application/octet-stream)
2006-11-08 14:43 EST, david schuller
no flags Details
Current Xorg.0.log (43.51 KB, text/plain)
2006-11-08 14:44 EST, david schuller
no flags Details

  None (edit)
Description david schuller 2006-11-03 10:43:18 EST
Description of problem:
When "intel" driver is specified in /etc/X11/xorg.conf and machine is rebooted,
monitor goes completely blank.

Version-Release number of selected component (if applicable):
I don't know which package contains the "intel" driver. xorg-x11-drivers-7.1-3 
xorg-x11-drv-i810-1.6.5-9.fc6 xorg-x11-server-Xorg-1.1.1-47.fc6
How reproducible:
Completely

Steps to Reproduce:
1. setup /etc/X11/xorg.conf file to use "intel" driver
2. reboot
3. 
  
Actual results:
Blank screen

Expected results:
X login screen

Additional info: Hardware is Commell LV-677 mobo with intel 945GM chipset and
Intel Core 2 Duo (Merom) CPU. Typical LCD monitor is attached to the VGA connector.
Comment 1 david schuller 2006-11-03 10:43:18 EST
Created attachment 140259 [details]
X log file
Comment 2 david schuller 2006-11-03 10:44:56 EST
Created attachment 140260 [details]
X config file
Comment 3 david schuller 2006-11-03 10:46:48 EST
Created attachment 140261 [details]
output from dmesg

Does the second last line mean anything: ACPI: PCI Interrupt... ?
Comment 4 david schuller 2006-11-03 16:09:37 EST
Created attachment 140322 [details]
X log file from startx

set inittab level to 3, started from "startx". Screen is all blank. Network
link is still OK.
Comment 5 Parag Warudkar 2006-11-06 15:29:54 EST
This happens to me on FC6/X86 on Dell E1705 as well. I have to revert to using
915resolution and i810 driver to get the LCD native resolution. (Intel driver
makes the display go blank.)
Comment 6 david schuller 2006-11-06 17:34:58 EST
X driver "intel" also fails for me with the same hardware and the FC6 i386
distribution.
Comment 7 david schuller 2006-11-06 17:36:49 EST
Created attachment 140521 [details]
Xorg.0.log with intel driver and i386 distribution of FC6
Comment 8 david schuller 2006-11-08 14:42:18 EST
I am making some progress. I am back to the x86_64 distribution. I added a
"MonitorLayout" command to my xorg.conf, and now I get a display on my monitor.
The resolution was very low, so next I removed all resolutions except the
desired one from my Modes line. Now I get the appropriate resolution (1280x1024).

The system still reboots every time I log out.
Comment 9 david schuller 2006-11-08 14:43:37 EST
Created attachment 140699 [details]
My current xorg.conf file, with MonitorLayout, etc
Comment 10 david schuller 2006-11-08 14:44:32 EST
Created attachment 140700 [details]
Current Xorg.0.log
Comment 11 Adam Jackson 2007-04-10 18:36:13 EDT
As of xorg-x11-drv-i810-1.6.5-19.fc7, 915GM and all 945 and 965 chips will use
the intel modesetting driver by default.  Please update, and test with that
driver, and reopen if you have further issues.
Comment 12 Parag Warudkar 2007-04-10 19:01:24 EDT
Just to confirm - the latest intel driver works for me even in latest patched 
FC6 - on both x86_64 and i386. (Hardware is Macbook and MacMini with cinema 
display).

It does the right mode setting in both cases. Thanks.

Note You need to log in before you can comment on or make changes to this bug.