Bug 213922 - Implement testcase crashing kernel BZ 209118
Summary: Implement testcase crashing kernel BZ 209118
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Len DiMaggio
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-03 19:35 UTC by Jan Kratochvil
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-27 11:14:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Increase the number of ptrace(2)d processes of TestTaskForkedObserver to the max (661 bytes, patch)
2006-11-12 19:31 UTC, Jan Kratochvil
no flags Details | Diff
Some trivia 16x repeating of the TestTaskForkedObserver testcase (1.02 KB, patch)
2006-11-12 20:12 UTC, Jan Kratochvil
no flags Details | Diff

Description Jan Kratochvil 2006-11-03 19:35:25 UTC
Bug 209118 describes kernel crashing conditions by the gdb testcases:
chng-syms.exp checkpoint.exp

frysk should include this isolated invocation in its testsuite:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/frysk-imports/tests/?cvsroot=frysk

Related Bugs are: Bug 213554, Bug 207002, Bug 212736, Bug 209118, Bug 210249.

Requested by: cagney@redhat.com

Comment 1 Jan Kratochvil 2006-11-12 19:31:06 UTC
Created attachment 141005 [details]
Increase the number of ptrace(2)d processes of TestTaskForkedObserver to the max

As Bug 209118 / Prarit Bhargava found that the crashing reason is most probably
race during exiting of ptrace(2)d processes I just found the existing
TestTaskForkedObserver to be the optimal testcase for it.
It can get more harnessed by increasing the number of ptrace(2)d processes
there [attachment] but it is not needed at all.
while :;do ./TestRunner frysk.proc.TestTaskForkedObserver;done

Comment 2 Jan Kratochvil 2006-11-12 20:12:25 UTC
Created attachment 141006 [details]
Some trivia 16x repeating of the TestTaskForkedObserver testcase

Comment 3 Jan Kratochvil 2007-01-27 11:14:09 UTC
The requested testcase was already implemented as `TestTaskForkedObserver'.
The testsuite was crashing the kernel before already.
The problem looks fixed for me since kernel-2.6.18-1.3002.el5 as announced in
Bug 209118 Comment 37.



Note You need to log in before you can comment on or make changes to this bug.