Bug 213935 - Session settings are not completely saved
Session settings are not completely saved
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 15:41 EST by Michael Cronenworth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 13:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 310577 None None None Never

  None (edit)
Description Michael Cronenworth 2006-11-03 15:41:01 EST
Description of problem: When you setup plugins such as the Terminal and CVS
plugins they work fine, but when you close and reopen Anjuta they are no longer
activated. This isn't expected of Anjuta is it? I'm tired of having to
reactivate CVS and Terminal every day.


Version-Release number of selected component (if applicable): 2.0.2


How reproducible: Always


Steps to Reproduce:
1. Open Anjuta and activate the Terminal and CVS plugins.
2. Close Anjuta
3. Reopen Anjuta to see the plugins not active.
  
Actual results:


Expected results: Plugin settings are supposed to be saved - I hope.


Additional info: This also affects the toolbar layout. I have two toolbars on
one line, but every time I reopen Anjuta it is reset to a two line setup.
Comment 1 Paul F. Johnson 2006-11-03 16:11:42 EST
I'm not seeing either of these on my system - I've played with the toolbars and
the plugins, quit, restarted and they're in the same state as when I quit.

How are you quitting?
Comment 2 Michael Cronenworth 2006-11-03 16:48:56 EST
File -> Quit
or the X widget for the window.

Either way I close it it doesn't save it when I reopen it.

I have even moved my "~/.anjuta" directory and let it create a new one. It still
doesn't save my session settings (plugins not active, layout the default).

I'm using XFCE for my DE btw... not sure if it is something Gnome dependent.
Comment 3 Michael Cronenworth 2006-11-06 09:36:44 EST
Let me add that it will remember the documents I had open at the time of close.
Any other type of setting is not saved.
Comment 4 Michael Cronenworth 2006-11-15 17:09:49 EST
Anjuta bug# 310577 is the same as this one.

http://bugzilla.gnome.org/show_bug.cgi?id=310577

Looks like this bug has been around for over a year.
Comment 5 Michael Cronenworth 2006-12-22 15:00:19 EST
After reading the last post in the Gnome Bugzilla, I looked at my
~/.anjuta/sessions folder and sure enough those files are being *deleted* and
recreated every time I start Anjuta. Even if I set the files to "chown
root:root" they are *deleted* and recreated - big problem.

If I set the folder to "root:root" then the files are no longer touched (of
course), but Anjuta doesn't bother to read them and doesn't load any of my
plugins or my dock layouts. How annoying. I guess since none of the Anjuta
developers experience this (I don't see how they arn't) this isn't very high
priority.
Comment 6 Michael Cronenworth 2006-12-22 15:29:45 EST
OK, I've been snooping around and I found your mailing list thread.

http://sourceforge.net/mailarchive/forum.php?thread_id=30940515&forum_id=7093

The workaround is to start a real project and after that it will remember your
plugins. The dock layout still doesn't get saved, but hopefully they'll get this
bug fixed soon (seems like a simple file i/o issue...).
Comment 7 Paul F. Johnson 2006-12-24 11:24:13 EST
I'm going to build the CVS tarball tonight (beer dependent!) and release it for
rawhide. It should fix lots of problems.
Comment 8 Paul F. Johnson 2007-01-21 06:47:46 EST
Can you try the version in rawhide (you'll need to update gnome-build and
anjuta-gdl at the same time) and let me know if this sorts the problem. If it
does, I'll give it a week and get it into core.
Comment 9 Michael Cronenworth 2007-01-22 09:45:31 EST
You also need to add graphviz to the list of required packages to update.

This did not fix it though. I moved my .anjuta directory off and let it have a
fresh settings directory. Nothing changed between 2.0.1 and 2.1.0. :(
Comment 10 Michael Cronenworth 2007-05-31 17:06:24 EDT
I've updated to Fedora 7 and the behavior is still the same. :(
Comment 11 Michael Cronenworth 2007-06-22 15:30:44 EDT
There's several new versions available... is it possible to push through a
package update to 2.1.3 and see if this is resolved?
Comment 12 Michael Cronenworth 2007-09-18 13:08:44 EDT
Holy cow! I updated to the 2.2.0-2.fc7 package released recently and it fixes
this nasty bug! Yay!

Note You need to log in before you can comment on or make changes to this bug.