Bug 213961 - FC6 install failure: DB_VERSION_MISMATCH: Database environment version mismatch
FC6 install failure: DB_VERSION_MISMATCH: Database environment version mismatch
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 17:32 EST by Steven P. Ulrick
Modified: 2008-05-06 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump from the failed install described in the bug report (155.85 KB, text/plain)
2006-11-03 17:32 EST, Steven P. Ulrick
no flags Details

  None (edit)
Description Steven P. Ulrick 2006-11-03 17:32:34 EST
Description of problem:
While attempting a http install of Fedora Core 6, everything went fine until it
got to the part where it was transferring the install image to the hard drive &
then starting the installation transaction (if I got those two items reversed, I
do apologize.  Also, the descriptions are approximate.)

Version-Release number of selected component (if applicable):
11.1.1.3-1

How reproducible:
Just attempt a http install on the machine that it failed on.

Steps to Reproduce:
1. Boot FC6 disc 1 | linux askmethod
2. Choose "Http"
3. Choose "mirrors.kernel.org" as the site, and "/fedora/core/6/i386/os" as the
directory.
4. Follow whatever other steps that would normally come after step 3.
5. Wait....  Then the screen comes up that gave me the option to save the error
report to a floppy disk.  Which you will find attached to this report.
  
Actual results:
Failed Install.

Expected results:
Fully functioning, though admittedly minimal, install of Fedora Core 6.

Additional info:
I had tried installs earlier in the day using CDROM's, and they failed with
similar errors.  I tried http install because my Fedora install because I was
just trying to get a running system.

I will Gladly get you any more info that you need.  But I do need to travel a
short distance to get to the machine :(

I rated this "High" severity because it keeps Anaconda from fulfilling it's purpose.
Comment 1 Steven P. Ulrick 2006-11-03 17:32:34 EST
Created attachment 140333 [details]
Anaconda dump from the failed install described in the bug report
Comment 2 Steven P. Ulrick 2006-11-06 11:42:39 EST
I discovered the thing that was keeping the installation from proceeding when I
was attempting it with Local CDROM's was this little darling:

/mnt/sysimage/root/install.log:
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database
environment version mismatch
error: cannot open Packages database in /mnt/sysimage/var/lib/rpm

I looked at that again this morning, and then I realized that I have a /var
partition that already has a /var/lib/rpm in it from my FC3 install.  So I tried
deleting the /var partition and used that space for /usr/local.  The result is
that I now have Fedora Core 6 installed and running on that machine....

I have no idea whatsoever, since I don't have a /var partition on my home
system, but did Anaconda/Fedora behave as they should have?  If they did, how
does one go about having a /var partition, since their is usually an old RPM
database hanging out there?  It's not a big deal, just wondering.  As far as the
reason for filing this report is concerned, this bug is now a non-issue, unless
Anaconda/Fedora did not deal with my /var partition correctly.
Comment 3 Red Hat Bugzilla 2007-08-21 01:29:05 EDT
User pnasrat@redhat.com's account has been closed
Comment 4 Bug Zapper 2008-04-04 00:24:11 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 12:41:28 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.