Bug 213989 - Installation of FC6 hangs at point "Searching for Fedora Core installations"
Installation of FC6 hangs at point "Searching for Fedora Core installations"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 06:40 EST by Jongi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 12:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jongi 2006-11-04 06:40:51 EST
Description of problem:

I have tested the DVD iso I downloaded. The SHA1SUM and testing it when booting
from the disk show the iso as being a valid Fedora Core 6 DVD.

I have tried to run the install with all of the following options at the prompt:

<Enter>
linux
linux reiserfs selinux=0
inux reiserfs selinux=0 ide=nodma
linux reiserfs selinux=0 acpi=off
linux reiserfs selinux=0 text
linux selinux=0
linux rescue (you will see below why I did this one)

No matter which of the above options I use, the installer will freeze 10-15
after the "Searching for Fedora Core installations" dialog box appears.

I currently have FC5 (amongst other distros) installed on this system. So I
thought to myself what would happen if I tried to install FC5. I went with:
linux reiserfs selinux=0

At the "Searching for Fedora Core installations" the following error message
pops up:

Error mounting file system on hdd8:
Operation not supported


The same error occurs for sda12 and sda13. Interestingly hdd8, sda12, sda13 and
sda14 are part of LVM. What was also of interest is that the error message did
not pop up for sda14. The same happens when I boot of the FC5 DVD and run: linux
rescue.

[root:~#] pvscan
  PV /dev/sda14   VG Home    lvm2 [32.88 GB / 0    free]
  PV /dev/sda13   VG Store   lvm2 [30.00 GB / 0    free]
  PV /dev/hdd8    VG Store   lvm2 [30.31 GB / 0    free]
  PV /dev/sda12   VG Games   lvm2 [39.99 GB / 0    free]
  Total: 4 [133.18 GB] / in use: 4 [133.18 GB] / in no VG: 0 [0   ]

I have a suspicion this might have something to do with the SATA drive
(ST3250620AS) and/or the fact that the LVM spans across the SATA and IDE drive.

For completeness sake I will also include the output of fdisk l

[root:~#] fdisk -l


Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        9963    80027766    7  HPFS/NTFS


Disk /dev/hdd: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System

/dev/hdd1   *           1       31222    15735636    c  W95 FAT32 (LBA)
/dev/hdd2           31222      158816    64307565+   5  Extended
/dev/hdd5           31222       62444    15735636   83  Linux
/dev/hdd6           62444       93665    15735636   83  Linux

/dev/hdd7           93665       95753     1052226   82  Linux swap / Solaris
/dev/hdd8           95754      158816    31783718+  83  Linux

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       30401   244196001    5  Extended
/dev/sda5               1        2611    20972794+  83  Linux

/dev/sda6            2612        5222    20972826   83  Linux
/dev/sda7            5223        7180    15727603+  83  Linux
/dev/sda8            7181        9138    15727603+  83  Linux
/dev/sda9            9139       11096    15727603+  83  Linux

/dev/sda10          11097       13054    15727603+  83  Linux
/dev/sda11          13055       16971    31463271    7  HPFS/NTFS
/dev/sda12          16972       22192    41937651   83  Linux
/dev/sda13          22193       26108    31455238+  83  Linux

/dev/sda14          26109       30401    34483491   83  Linux

Disk /dev/dm-0: 35.3 GB, 35307651072 bytes
255 heads, 63 sectors/track, 4292 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes


Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 64.7 GB, 64751665152 bytes
255 heads, 63 sectors/track, 7872 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/dm-1 doesn't contain a valid partition table


Disk /dev/dm-2: 42.9 GB, 42941284352 bytes
255 heads, 63 sectors/track, 5220 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/dm-2 doesn't contain a valid partition table


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-11-06 11:01:00 EST
When it hangs, cna you still switch ttys?
Comment 2 Jongi 2006-11-07 13:43:57 EST
I've tried the function combiantions for Ctrl, Alt and Ctrl-Alt eg Ctrl-Alt F3.
The system is frozen. Even Numlock doesn't light up when I press it. The circle
thing around the pointer also stops spinning and just stays in the position it
was. Mouse doesn't move.

So what I did was to remove the SATA drive, unplugged the SATA cable from the
motherboard. Put in the FC6 install DVD and when it got to the same point, it
moved on to the point where it asked me to upgrade or install. I chose install
and the screen went blank and froze (waited for less than 5 minutes at that screen).

So my SATA suspicions have proved to be somewhat correct I would suspect. This
is the SATA info from FC5:

[root:~#] lsmod | grep sata
sata_via               10693  3
libata                 99161  1 sata_via

[root:~#] lspci | grep SATA
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller
(rev 80)

[root:~#]lspci -v (selected portion)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller
(rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Giga-byte Technology GA-7VM400AM(F) Motherboard
        Flags: bus master, medium devsel, latency 32, IRQ 169
        I/O ports at 9400 [size=8]
        I/O ports at 9800 [size=4]
        I/O ports at 9c00 [size=8]
        I/O ports at a000 [size=4]
        I/O ports at a400 [size=16]
        I/O ports at a800 [size=256]
        Capabilities: [c0] Power Management version 2

[root:~#] lspci -n | grep 00:0f.0
00:0f.0 0101: 1106:3149 (rev 80)

[root:~#] grep 1106 /lib/modules/2.6.18-1.2200.fc5/modules.pcimap | grep 3149
sata_via             0x00001106 0x00003149 0xffffffff 0xffffffff 0x00000000
0x00000000 0x0

[root:~#] modinfo sata_via
filename:       /lib/modules/2.6.18-1.2200.fc5/kernel/drivers/scsi/sata_via.ko
author:         Jeff Garzik
description:    SCSI low-level driver for VIA SATA controllers
license:        GPL
version:        2.0
vermagic:       2.6.18-1.2200.fc5 mod_unload 686 REGPARM 4KSTACKS gcc-4.1
depends:        libata
alias:          pci:v00001106d00000591sv*sd*bc*sc*i*
alias:          pci:v00001106d00003149sv*sd*bc*sc*i*
alias:          pci:v00001106d00003249sv*sd*bc*sc*i*
srcversion:     826D41190D62A5FFC744E90
Comment 3 Jongi 2006-11-08 16:26:34 EST
I loaded with linux reiserfs selinux=0 noprobe and chose the ahci driver. This
time it went past the Searching for Fedora Core installations sections but hung
after I chose to install a fresh install.

I should have added that the motherboard I am using is the Gigabyte
GA-8VM800M-775 with the SATA controller VIA VT8237R.
Comment 4 Jongi 2006-11-29 17:36:09 EST
Sometimes the solution is staring you in the face but you do not see it. The
problem seems to be solved (the install process moves past the two hang points.
But I have not gone further in the install process as I am about to go to bed.
Will install tomorrow though).

Anyway, there are 2 partitions I wanted to resize for some time (sda5 and sda6).
I happened to have loaded XP the other day and fired up Acronis Disk Suite. This
gave me errors about reading some of the drives. Incidentally gparted had
stalled when I had some weeks before first tried to repartition but I closed it
before any error messages came up. 

Anyway, when I have previously loaded rescue of the FC5 disk the following error
has also come up

[code]
Error mounting file system on hdd8:
Operation not supported[/code]

The same error occurs for sda12 and sda13.

So I decided to do a fsck on the drives. Doing the fsck on the lv partitions
meant when I next tried the FC6 install it gave every indication that it would
complete without a problem.

I will install tomorrow and inform whether that completes without a problem.
Comment 5 Jongi 2006-11-30 12:07:15 EST
FC6 installed without issues. Though it is not a bug maybe it would be a good
idea, if possible, to have a way of the installer to check partitions for errors.

Note You need to log in before you can comment on or make changes to this bug.