Bug 2140197 - xdg-open raises avoidable warning regarding grep-3.8 [bug 2123935]
Summary: xdg-open raises avoidable warning regarding grep-3.8 [bug 2123935]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-utils
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2189126 (view as bug list)
Depends On: 2123935
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-04 19:08 UTC by Jan Pokorný [poki]
Modified: 2023-09-24 03:11 UTC (History)
5 users (show)

Fixed In Version: xdg-utils-1.1.3-15.fc38 xdg-utils-1.1.3-15.fc39 xdg-utils-1.1.3-15.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-10 01:20:20 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jan Pokorný [poki] 2022-11-04 19:08:29 UTC
Hi, just noticed this:

$ xdg-open https://fedoraproject.org
> egrep: warning: egrep is obsolescent; using grep -E

(more informative demo with a pun intended for a little bit of fun:
$ egrep egrep $(which xdg-open)
> egrep: warning: egrep is obsolescent; using grep -E
>             || ! echo "$1" | egrep -q '^[[:alpha:]][[:alpha:][:digit:]+\.\-]*:'; then
)

$ rpm -qf $(which grep xdg-open)
grep-3.8-1.fc38.x86_64
xdg-utils-1.1.3-12.fc37.noarch

See also the announcement
https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html:

>   The egrep and fgrep commands, which have been deprecated since
>   release 2.5.3 (2007), now warn that they are obsolescent and should
>   be replaced by grep -E and grep -F.

Also, for the sake of a more complete picture, note it looks like
Debian actually decided to revert the upstream change of raising those
compatibility warnings:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1019335

No particular opinion here, just following what's currently in Fedora
and assuming that Fedora is more prudent regarding the divergence
from upstream, which would favour adapting xdg-utils to this new
constrain than the other way around.

No upstream bug seems to exist for xdg-utils at this time.

Comment 2 Jouni Seppänen 2023-04-24 10:52:34 UTC
*** Bug 2189126 has been marked as a duplicate of this bug. ***

Comment 3 Ewoud Kohl van Wijngaarden 2023-07-19 14:54:09 UTC
https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/66 is not merge yet, but it would be good to apply this downstream until it's resolved upstream. Just to avoid the warning all the time.

Comment 4 Rafael Jeffman 2023-07-25 19:34:47 UTC
To fix this issue, I'm proposing https://src.fedoraproject.org/rpms/xdg-utils/pull-request/2

Comment 5 Sergio Basto 2023-09-07 23:16:15 UTC
This was already fixed upstream ( hopefully )  

https://gitlab.freedesktop.org/xdg/xdg-utils/-/commit/6519ca76246c3c1ad941d3117d4e3a2d4a1dc599

Comment 6 Fedora Update System 2023-09-08 00:17:58 UTC
FEDORA-2023-b76ca33423 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b76ca33423

Comment 7 Fedora Update System 2023-09-08 00:18:21 UTC
FEDORA-2023-0d30eafc36 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-0d30eafc36

Comment 8 Fedora Update System 2023-09-08 00:18:38 UTC
FEDORA-2023-a39ab76b73 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-a39ab76b73

Comment 9 Fedora Update System 2023-09-09 01:50:03 UTC
FEDORA-2023-0d30eafc36 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-0d30eafc36`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-0d30eafc36

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-09-09 01:52:12 UTC
FEDORA-2023-b76ca33423 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b76ca33423`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b76ca33423

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-09-09 02:34:11 UTC
FEDORA-2023-a39ab76b73 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-a39ab76b73`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-a39ab76b73

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-09-10 01:20:20 UTC
FEDORA-2023-0d30eafc36 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2023-09-24 00:16:18 UTC
FEDORA-2023-b76ca33423 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2023-09-24 03:11:35 UTC
FEDORA-2023-a39ab76b73 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.