Bug 214029 - Bad svg file causes nautilus to crash continuously
Bad svg file causes nautilus to crash continuously
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: librsvg2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 15:43 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 01:09:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-04 15:43:59 EST
Put the following into the file ~/Desktop/foo.svg:

<svg>
        <defs>
                <polygon id="buggy" />
        </defs>

        <g id="buggy">
                <use xlink:href="#buggy" />
        </g>
</svg>

and watch nautilus crash in a loop.

This was originally filed as http://bugzilla.gnome.org/show_bug.cgi?id=361267
and is fixed in librsvg 2.16.1. Since librsvg 2.16.1 contains some more
important bugfixes besides this one, I recommend to update to 2.16.1 before
RHEL5
Comment 1 RHEL Product and Program Management 2006-11-04 16:04:37 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 2 Matthias Clasen 2006-11-06 12:06:44 EST
fix in librsvg2-2.16.1-1.el5, r-e mail sent
Comment 3 Nicole Dai 2006-11-09 01:23:01 EST
Reproduced the bug in librsvg2-2.16.0-2.fc6 and verified it has been fixed in
librsvg2-2.16.1-1.el5. The bug will be resolved when the package is added to the
tree.
Comment 4 Xiaohong Wang 2006-12-04 01:09:21 EST
librsvg2-2.16.1-1.el5 has been included in RHEL5-Client-20061201.0, so resolve
this bug.

Note You need to log in before you can comment on or make changes to this bug.