Bug 214035 - soundconverter fails silently
soundconverter fails silently
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: soundconverter (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 17:04 EST by Greg Martyn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 10:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Martyn 2006-11-04 17:04:27 EST
Description of problem:
soundconverter fails silently (except for stack trace output to the console)


Version-Release number of selected component (if applicable):
0.9.3

How reproducible:
Always

Steps to Reproduce:
Queue up a bunch of files to convert. I was converting flac=>mp3. 
Click "Convert"

Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2103, in on_convert_button_clicked
    self.do_convert()
  File "/usr/bin/soundconverter", line 2073, in do_convert
    self.converter.run()
  File "/usr/bin/soundconverter", line 496, in run
    self.setup()
  File "/usr/bin/soundconverter", line 615, in setup
    self.tasks[0].setup()
  File "/usr/bin/soundconverter", line 695, in setup
    self.play()
  File "/usr/bin/soundconverter", line 745, in play
    self.pipeline = gst.parse_launch(self.command)
gobject.GError: no element "id3v2mux"
  
Actual results:


Expected results:


Additional info:
Comment 1 cornel panceac 2006-11-07 13:24:05 EST
same here, on fc5. all gstreamer* installed except *devel and *debuginfo

yum provides id3v2mux says no match found even with freshrpms and livna repos
enabled
Comment 2 cornel panceac 2006-11-07 13:37:14 EST
i've done:

yum remove soundconverter && yum install soundconverter-0.9.2-1.fc5

and seems to be working now.
Comment 3 Denis Leroy 2006-11-07 20:10:52 EST
I apologize, though to my defense this new id3v2mux dependency was not made
explicit in the ChangeLog.

The problem is id3v2mux is normally part of gstreamer-plugins-good, but it is
not built in Fedora because it requires libtag which is in Extras (while
gstreamer-plugins-good is in Core), and we can't have Core to Extras
dependencies as of yet.

The solution is either to
1) get taglib in core. Hard :-(
2) submit a new gstreamer-plugins-good-taglib package to Extras. Slow :-(

For the time being, I've added a patch to only use id3v2mux if it is detected on
the system. That should fix this bug.
Comment 4 Denis Leroy 2006-11-08 10:04:09 EST
Fix pushed for FC 4 to 7.

Note You need to log in before you can comment on or make changes to this bug.