Bug 214036 - Kernel stalls when probing IDE on an Asus S5200A Intel Centrino based laptop
Kernel stalls when probing IDE on an Asus S5200A Intel Centrino based laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 17:13 EST by Ville-Pekka Vainio
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.18-1.2849.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 16:14:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2006-11-04 17:13:06 EST
Description of problem:
The boot process stalls for several seconds when the kernel is probing for IDE
and hard disks on an Asus S5200A. When booting has finally advanced to loading
udev, it too stalls for a long time. After that, everything works normally.

This is an Intel Centrino based laptop. Everything has worked ok on FC5 and I'm
currently using the latest FC5 kernel which does not have this problem.

The FC6 kernels (including the default one and the one currently in testing) are
 basically unusable on this machine, because fast boot times are essential on a
laptop.

This is the first bug I'm posting for Fedora, if you need any more information,
I'll be happy to provide it.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6 (but also affects the newest testing kernel
2.6.18-1.2835.fc6)

How reproducible:
Boot an Asus S5200A with the default FC6 kernel

Steps to Reproduce:
1. Boot
2. Wait
  
Actual results:
The kernel stalls when probing for IDE and the hard disk. When it finally
continues booting, the system stalls again when starting udev.

Expected results:
The kernel boots normally and udev loads normally, as when using the latest FC5
kernel on an otherwise updated FC6 system.

Additional info:

dmesg before the stalling point containing possibly important information (I
have not yet tried what the message says, because FC5 kernels boot with default
options, but I will after posting this):

PCI: BIOS Bug: MCFG area at e0000000 is not E820-reserved
PCI: Not using MMCONFIG.
PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=2
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:00:02.0
PCI quirk: region 0800-087f claimed by ICH6 ACPI/GPIO/TCO
PCI quirk: region 0480-04bf claimed by ICH6 GPIO
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
PCI: Transparent bridge - 0000:00:1e.0
PCI: Bus #02 (-#05) is hidden behind transparent bridge #01 (-#02) (try
'pci=assign-busses')
Please report the result to linux-kernel to fix this permanently

dmesg from about where the kernel stalls:

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH6: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 177
ICH6: chipset revision 4
**STALLS HERE**
ICH6: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
Probing IDE interface ide0...
**AND HERE**
hda: IC25N060ATMR04-0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
Probing IDE interface ide1...
hda: max request size: 512KiB
hda: 117210240 sectors (60011 MB) w/7884KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda3 hda4 < hda5 >
ide-floppy driver 0.99.newide

/sbin/lspci:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04)
01:03.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
01:03.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
01:03.2 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
01:03.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 08)
01:03.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 03)
01:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)
Comment 1 Ville-Pekka Vainio 2006-11-04 17:25:53 EST
I tested with the kernel option pci=assign-busses, it does not help. Now that
I've seen the boot process once again, here is an updated dmesg with the correct
stalling points:

ICH6: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
Probing IDE interface ide0...
**STALLS HERE**
hda: IC25N060ATMR04-0, ATA DISK drive
**AND HERE**
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Comment 2 Ville-Pekka Vainio 2006-11-12 03:39:04 EST
FYI, I tested with the brand new FC5 kernel, 2.6.18-1.2239.fc5. It doesn't have
this problem either. So it's just the FC6 kernels that aren't working correctly.
Comment 3 Ville-Pekka Vainio 2006-11-12 16:14:32 EST
Just installed the newest FC6 kernel, 2.6.18-1.2849.fc6. Everything is working
correctly now with this laptop. Thanks to whoever fixed it and thanks for
providing this update.

Note You need to log in before you can comment on or make changes to this bug.