Bug 214060 - please update wireless-tools to v29 (ipw3945, 64bit problems)
please update wireless-tools to v29 (ipw3945, 64bit problems)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: 223161
  Show dependency treegraph
 
Reported: 2006-11-05 04:22 EST by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 11:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2006-11-05 04:22:57 EST
Description of problem:

The wireless-tools shiped in FC6 is seems to be version 28:
wireless-tools-28-1.fc6, but there seems to be problem with it when used with
the ip3945 driver:
(from the ISSUES file shipped with the driver):
"
13. Problem with some wireless commands on 64-bit systems

Due to an issue in handling 64-bit integers in the v28 based versions of 
the wireless tools, we recommend that only wireless tools based on v29 be 
used on 64-bit platforms."
So can we have a new wireless-tools packafe basen on v29?
Comment 4 drago01 2007-04-21 19:18:47 EDT
even f7 still uses v28... any update plans?
Comment 5 Christopher Aillon 2007-04-21 19:28:29 EDT
28 is the latest stable release.  We'll pull in 29 when it's released/closer to
stable.  Even if it was stable, we are past feature freeze at this point.  Bugs
that request version updates are largely useless, really.  I can simply patch
the version to say 29 if all you care about is numbers.

If you care about stuff working though, I can fix bugs if you file bugs on the
problems you are having.  The 64 bit patch is fairly small and we can probably
backport that.  ipw3945 works fine using wireless tools 28 for many people,
though I imagine they are using 32 bit machines.
Comment 6 drago01 2007-04-22 02:52:45 EDT
(In reply to comment #5)
> 28 is the latest stable release.  We'll pull in 29 when it's released/closer to
> stable.  Even if it was stable, we are past feature freeze at this point.  Bugs
> that request version updates are largely useless, really.  I can simply patch
> the version to say 29 if all you care about is numbers.
> 
no I don't care about numbers but about bugs.
> If you care about stuff working though, I can fix bugs if you file bugs on the
> problems you are having.  The 64 bit patch is fairly small and we can probably
> backport that.  ipw3945 works fine using wireless tools 28 for many people,
> though I imagine they are using 32 bit machines.
I use it on x86_64 to and it works fine but I cannot assiciote with some APs
when using networkmanger, while searching for the reason while this might be
happing I read the readme of the ipw3945 driver and found the text above. So I
thoight this may be related to my problems (I might be wrong because
wpa_supplicant works).
Comment 7 Christopher Aillon 2007-05-01 11:41:29 EDT
If wpa_supplicant works, then you're probably wrong.  Though our wireless tools
does have the 64bit fixes in it now.  Closing this one as cantfix since 29 isn't
out yet.

Note You need to log in before you can comment on or make changes to this bug.