Bug 214090 - g-p-m crashes..... produces bug report attached
g-p-m crashes..... produces bug report attached
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 12:13 EST by Tom London
Modified: 2013-03-05 22:47 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 10:17:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report from crash (6.96 KB, text/plain)
2006-11-05 12:13 EST, Tom London
no flags Details
Another crash bug report (7.07 KB, text/plain)
2006-11-05 14:18 EST, Tom London
no flags Details
debuginfo bug report of g-p-m crashing on gdm startup (5.87 KB, text/plain)
2006-11-05 21:41 EST, Tom London
no flags Details
Another crash bug report from bug buddy (not sure if it is different) (5.81 KB, text/plain)
2006-11-06 09:26 EST, Tom London
no flags Details
gnome-power-manager backtrace (11.05 KB, text/plain)
2006-11-10 18:35 EST, Jay Cliburn
no flags Details

  None (edit)
Description Tom London 2006-11-05 12:13:56 EST
Description of problem:
gnome-power-manager crashes at every startup.


Version-Release number of selected component (if applicable):
gnome-power-manager-2.17.2.1-1.fc7

How reproducible:
Every time


Steps to Reproduce:
1. run 'gnome-power-manager'
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2006-11-05 12:13:56 EST
Created attachment 140402 [details]
Bug report from crash
Comment 2 Tom London 2006-11-05 12:17:14 EST
When this happens, haldaemon (hal-0.5.8.1-4.fc6) seems to crash.
Comment 3 Tom London 2006-11-05 14:06:00 EST
I got it to work again by moving the existing ~/.gconf/apps/gnome-power-manager
directory out of the way.

Running g-p-m creates a new one.

Here is diff output of 'new' against 'old':

[tbl@localhost apps]$ diff gnome-power-manager ../gnome-power-manager
diff gnome-power-manager/%gconf.xml ../gnome-power-manager/%gconf.xml
3,4c3
<         <entry name="display_icon_policy" mtime="1162753313" type="string">
<                 <stringvalue>always</stringvalue>
---
>         <entry name="enable_pcskr_beeping" mtime="1162168018" type="bool"
value="false">
6,8c5
<         <entry name="enable_pcskr_beeping" mtime="1162753305" type="bool"
value="false">
<         </entry>
<         <entry name="action_ups_low" mtime="1162753305" type="string">
---
>         <entry name="action_ups_low" mtime="1162168018" type="string">
11c8
<         <entry name="action_ups_critical" mtime="1162753305" type="string">
---
>         <entry name="action_ups_critical" mtime="1162168018" type="string">
14c11
<         <entry name="action_battery_critical" mtime="1162753305" type="string">
---
>         <entry name="action_battery_critical" mtime="1162168018" type="string">
17c14
<         <entry name="use_lowpower_battery" mtime="1162753305" type="bool"
value="true">
---
>         <entry name="use_lowpower_battery" mtime="1162168018" type="bool"
value="true">
19,20c16,17
<         <entry name="action_battery_button_lid" mtime="1162753305" type="string">
<                 <stringvalue>blank</stringvalue>
---
>         <entry name="action_battery_button_lid" mtime="1162168018" type="string">
>                 <stringvalue>suspend</stringvalue>
22,23c19,20
<         <entry name="action_button_suspend" mtime="1162753305" type="string">
<                 <stringvalue>nothing</stringvalue>
---
>         <entry name="action_button_suspend" mtime="1162168018" type="string">
>                 <stringvalue>suspend</stringvalue>
25c22
<         <entry name="action_button_power" mtime="1162753305" type="string">
---
>         <entry name="action_button_power" mtime="1162168018" type="string">
34c31
<         <entry name="display_state_change" mtime="1162753305" type="bool"
value="true">
---
>         <entry name="display_state_change" mtime="1162168018" type="bool"
value="true">
36c33
<         <entry name="display_dim_on_idle" mtime="1162753305" type="bool"
value="true">
---
>         <entry name="display_dim_on_idle" mtime="1162168018" type="bool"
value="true">
40,41c37,38
<         <entry name="action_battery_sleep_type" mtime="1162753305" type="string">
<                 <stringvalue>nothing</stringvalue>
---
>         <entry name="action_battery_sleep_type" mtime="1162168017" type="string">
>                 <stringvalue>suspend</stringvalue>
43c40
<         <entry name="action_ac_sleep_type" mtime="1162753305" type="string">
---
>         <entry name="action_ac_sleep_type" mtime="1162168017" type="string">
46,47c43,44
<         <entry name="action_ac_button_lid" mtime="1162753305" type="string">
<                 <stringvalue>blank</stringvalue>
---
>         <entry name="action_ac_button_lid" mtime="1162168018" type="string">
>                 <stringvalue>suspend</stringvalue>
[tbl@localhost apps]$ 
Comment 4 Tom London 2006-11-05 14:18:40 EST
Created attachment 140407 [details]
Another crash bug report

Sorry, next reboot reproduces original problem: g-p-m crashes. dump looks about
the same (attached), and haldaemon is dead.
Comment 5 Tom London 2006-11-05 15:40:50 EST
Booting again with the power cord pulled and with battery at 95% both haldaemon
and g-p-m are running.....

Above aborts were with power cord inserted and with battery at 100%.

Probably pulling at straws, but .....
Comment 6 Richard Hughes 2006-11-05 17:29:14 EST
Thanks Tom. Could you install the debuginfo files for both HAL and
gnome-power-manager please, and try to get the segfault again. Many thanks.

Richard,
Comment 7 Tom London 2006-11-05 18:52:56 EST
I installed the debuginfo packages, and of course, first reboot didn't produce
the crash.... sigh.
Comment 8 Tom London 2006-11-05 21:41:23 EST
Created attachment 140427 [details]
debuginfo bug report of g-p-m crashing on gdm startup

I think I got one with debuginfo....

Bug buddy report attached.....
Comment 9 Tom London 2006-11-05 21:53:33 EST
I ran 'gdb hald' (and run --daemon=no), and after it settled, I ran
'gnome-power-manager' in another window.

Got this from gdb/hald:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208088896 (LWP 3972)]
0x4edecc88 in strcmp () from /lib/libc.so.6
(gdb) 
(gdb) 
(gdb) 
(gdb) 
(gdb) 
(gdb) where
#0  0x4edecc88 in strcmp () from /lib/libc.so.6
#1  0x0805cc6f in hald_dbus_filter_handle_methods (connection=0x96cbf30, 
    message=0x96cc000, user_data=0x0, local_interface=0) at hald_dbus.c:3822
#2  0x0805d38b in hald_dbus_filter_function (connection=0x96cbf30, 
    message=0x96cc000, user_data=0x0) at hald_dbus.c:3934
#3  0x4fac34cb in dbus_connection_dispatch () from /lib/libdbus-1.so.3
#4  0x4fca5cfd in dbus_server_setup_with_g_main ()
   from /usr/lib/libdbus-glib-1.so.2
#5  0x4ef532d2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#6  0x4ef562af in g_main_context_check () from /lib/libglib-2.0.so.0
#7  0x4ef56659 in g_main_loop_run () from /lib/libglib-2.0.so.0
#8  0x08055fce in main (argc=2, argv=0xbfc65f84) at hald.c:582
#9  0x4ed96e5c in __libc_start_main () from /lib/libc.so.6
#10 0x0804c341 in _start ()
(gdb) 
Comment 10 Richard Hughes 2006-11-06 04:17:58 EST
Cool, thanks for that, that's 600% better to debug :-)

You're not running the latest DBUS are you?

Richard.
Comment 11 Tom London 2006-11-06 09:26:10 EST
Created attachment 140478 [details]
Another crash bug report from bug buddy (not sure if it is different)

Attaching another crash report.

I am running (believe latest dbus):
dbus-devel-0.95-1.fc7
dbus-0.95-1.fc7
dbus-sharp-0.63-6.fc6
dbus-x11-0.95-1.fc7
dbus-glib-0.71-1.fc7
dbus-glib-devel-0.71-1.fc7
dbus-python-0.70-6

I see there are newer dbus-glib and dbus-glib-devel in today's updates
(0.71-2.fc7); I'll install them now ...
Comment 12 sangu 2006-11-06 10:35:00 EST
please see also bug 214027

this problem doesn't happen in dbus-0.94-1.fc7.
Comment 13 Tom London 2006-11-06 10:50:58 EST
No joy.

I created /var/lib/dbus, and now /var/lib/dbus/machine-id gets created (and no
boot time message), but the other symptoms are the same: haldaemon/g-p-m crashes.

I have /etc/dbus-1/machine-id, but it hasn't been touched since 25 October.

Richard, you want me to revert to dbus-0.94-1.fc7 or leave as is for debugging?
Comment 14 Richard Hughes 2006-11-06 14:06:36 EST
Tom, if you are running over DBUS 0.94 you'll need the HAL patches merged into
CVS about a week ago. See
http://lists.freedesktop.org/archives/hal/2006-November/006464.html

Richard.
Comment 15 Daniel Malmgren 2006-11-08 04:08:02 EST
I'd just like to confirm that I'm getting the same thing as Tom with todays
Rawhide. I didn't get it yesterday, so I guess it has to be dbus (as it's the
only thing that seems relevant in what was updated). Any way to provide any more
useful information?
Comment 16 Jay Cliburn 2006-11-10 18:35:51 EST
Created attachment 140947 [details]
gnome-power-manager backtrace
Comment 17 Jay Cliburn 2006-11-10 18:37:44 EST
I'm experiencing the same indications as the OP.  Comment #16 contains a
backtrace with debuginfo packages installed.
Comment 18 Daniel Malmgren 2006-11-15 08:36:03 EST
With today's rawhide (hal 0.5.8.1-6.fc7) everything seems to work fine for me again.

Note You need to log in before you can comment on or make changes to this bug.