Bug 214094 - Error creating plone site
Error creating plone site
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: plone (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 13:03 EST by Mads Kiilerich
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 19:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2006-11-05 13:03:35 EST
Description of problem:
When creating a plone site the response is>

Site Error

An error was encountered while publishing this resource.

Error Type: AttributeError
Error Value: previous


Version-Release number of selected component (if applicable):
plone-2.5.1-3.fc6

How reproducible:


Steps to Reproduce:
1. In Zope manager add a plone site
  
Actual results:
/var/lib/zope/log/event.log contains:
2006-11-05T18:51:18 ERROR Zope.SiteErrorLog
http://localhost:8080/manage_addProduct/CMFPlone/addPloneSite
Traceback (innermost last):
  Module ZPublisher.Publish, line 115, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 41, in call_object
  Module Products.CMFPlone.factory, line 44, in addPloneSite
  Module Products.GenericSetup.tool, line 251, in runAllImportSteps
   - __traceback_info__: profile-CMFPlone:plone
  Module Products.GenericSetup.tool, line 725, in _doRunImportStep
   - __traceback_info__: plone-final
  Module Products.CMFPlone.setuphandlers, line 211, in importFinalSteps
  Module Products.CMFPlone.setuphandlers, line 109, in setupPortalContent
  Module Products.CMFPlone.utils, line 368, in _createObjectByType
  Module Products.CMFCore.TypesTool, line 357, in _finishConstruction
  Module Products.CMFCore.CMFCatalogAware, line 145, in notifyWorkflowCreated
  Module Products.CMFCore.WorkflowTool, line 354, in notifyCreated
  Module Products.CMFCore.WorkflowTool, line 699, in _reindexWorkflowVariables
  Module Products.Archetypes.CatalogMultiplex, line 63, in reindexObjectSecurity
  Module Products.ZCatalog.CatalogBrains, line 52, in _unrestrictedGetObject
  Module OFS.Traversable, line 187, in unrestrictedTraverse
   - __traceback_info__: ([], 'previous')
  Module Products.Five.traversable, line 115, in __bobo_traverse__
AttributeError: previous


Expected results:


Additional info:
Seems to be http://dev.plone.org/plone/ticket/5774
Comment 1 Paul W. Frields 2006-11-22 17:51:45 EST
New 2.5.1-4 push fixes this issue for me.
Comment 2 Jonathan Steffan 2006-11-22 19:46:33 EST
Fixed

Note You need to log in before you can comment on or make changes to this bug.