Bug 214102 - postun problem yum removing libgcj
postun problem yum removing libgcj
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lucene (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 14:15 EST by Ben Konrath
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 20:15:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file showing postun problems removing libgcj (15.84 KB, text/plain)
2006-11-05 14:15 EST, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2006-11-05 14:15:12 EST
There was an error in the postun of the Lucene package when I yum removed
libgcj. Please refer to the attached log file for details. Thanks.
Comment 1 Ben Konrath 2006-11-05 14:15:13 EST
Created attachment 140405 [details]
log file showing postun problems removing libgcj
Comment 2 Deepak Bhole 2006-11-09 17:10:12 EST
FC6's lucene (1.4.2-1jpp.14) has a Requires(pre) and Requires(post) for
java-1.4.2-gcj-compat. However, the log shows that it is being uninstalled
before lucene is. This should not be happening... seems like an issue with yum.

Adding Jeremy to cc:.
Comment 3 Deepak Bhole 2006-11-09 17:12:15 EST
s/lucene (1.4.2-1jpp.14)/lucene (1.4.3.1jpp.14)
Comment 4 Ben Konrath 2006-11-09 17:15:18 EST
(In reply to comment #2)
> FC6's lucene (1.4.2-1jpp.14) has a Requires(pre) and Requires(post) for
> java-1.4.2-gcj-compat. However, the log shows that it is being uninstalled
> before lucene is. This should not be happening... seems like an issue with yum.

The Eclipse sub-packages have a Requires(postun) for java-gcj-compat as well and
as you can see they have the same problem. In fact the Eclipse packages leave
directories on the filesystem because the Requires(postun) ordering of the
sub-packages are not respected either.  
Comment 5 Jeremy Katz 2006-11-09 17:23:55 EST
Given that you were removing libgcc as well, this likely led to a number of dep
loops at which point, ordering can't be guaranteed
Comment 6 Ben Konrath 2006-11-09 20:15:45 EST
Since this isn't a bug, I'll close it. If I have come up with a test case
involving the eclispe alone, I'll file a bug against rpm.

Note You need to log in before you can comment on or make changes to this bug.