Bug 214116 - Rhythmbox won't play AAC files from my iTunes library (.m4a)
Rhythmbox won't play AAC files from my iTunes library (.m4a)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 15:43 EST by Guy Davis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 05:29:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Davis 2006-11-05 15:43:59 EST
Description of problem:
Ever since I upgraded from FC 4, I haven't been able to play my music collection
which was ripped by iTunes (I share it with a Mac user).  The files are AAC
format (.m4a) and are NOT the DRM-protected (.m4p) files from the iTunes store.

Version-Release number of selected component (if applicable):
Rhythmbox 0.9.5
gstreamer-tools-0.10.9-2
gstreamer-plugins-base-0.10.9-4
gstreamer-plugins-ugly-devel-0.10.4-3.lvn6
gstreamer-plugins-bad-devel-0.10.3-1.fc6
gstreamer-ffmpeg-0.10.1-4.lvn6
gstreamer-plugins-base-devel-0.10.9-4
gstreamer-devel-0.10.9-2
gstreamer-0.10.9-2
gstreamer-plugins-good-0.10.4-1.fc6
gstreamer-plugins-bad-0.10.3-1.fc6
gstreamer-python-0.10.5-2.fc6
gstreamer-plugins-ugly-0.10.4-3.lvn6
gstreamer-plugins-good-devel-0.10.4-1.fc6

How reproducible:
Every time I try to play them.  Since I upgraded from FC4.

1. Point Rhythmbox to a directory holding .m4a files. The files will load up in
the main browser window. (In FC6, now they don't even load, complain about a
gstreamer error.)
2. Try to play an .m4a file.
  
Actual results:
Rhythmbox either locks up or it will skip from song to song very quickly not
playing any.  Either way the program has to be killed at that point.

Expected results:
Play the song like FC4 used to do.

Additional info:
Comment 1 Guy Davis 2006-11-27 11:21:49 EST
Just checking to see if anyone has read this issue.  I'm not really expecting a
fix, but a response would be nice.  Even if the response is that FC6 explicitly
disallows AAC support for some reason.  Then maybe I could find a workaround?
Comment 2 Alexander Larsson 2006-11-28 05:29:32 EST
I have no idea why this changed. We won't have time to look into it though (due
to  time limitations). If you file a bug upstream you will probably get a better
response.

Note You need to log in before you can comment on or make changes to this bug.