Bug 214121 - No video output from FC6 on nVidia NV6 [Vanta/Vanta LT]
No video output from FC6 on nVidia NV6 [Vanta/Vanta LT]
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 16:07 EST by Wojciech Pilorz
Modified: 2009-07-14 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original xorg.conf (not working for my setup) (565 bytes, text/plain)
2006-11-05 16:07 EST, Wojciech Pilorz
no flags Details
modified /etc/X11/xorg.conf which works for me (862 bytes, text/plain)
2006-11-05 16:11 EST, Wojciech Pilorz
no flags Details
/var/log/Xorg.0.log with original xorg.conf file (no video visible) (54.77 KB, text/plain)
2006-11-05 16:12 EST, Wojciech Pilorz
no flags Details
/var/log/Xorg.0.log with modified xorg.conf file (video visible OK) (52.92 KB, text/plain)
2006-11-05 16:13 EST, Wojciech Pilorz
no flags Details

  None (edit)
Description Wojciech Pilorz 2006-11-05 16:07:26 EST
Description of problem:
While installation went OK in graphical mode, after the installation 
completed X gave no graphical output (CRT led seems indicate no-signal or
power-saving mode) until I modified /etc/X11/xorg.conf using some lines from
Fedora Core 4 install

[note: I had the same problem with FC6test3]

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-1.2.0-4.fc6


How reproducible:
Do not know generally; on my setup it happenes with originial xorg.conf both
aftrer FC6test3 and FC6 installation

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No video output unless /etc/X11/xorg.conf modified

Expected results:
Should work out of the box, like in Fedora Core 4

Additional info:
I am including as attachements original and modified xorg.conf and xorg log files.
Comment 1 Wojciech Pilorz 2006-11-05 16:07:26 EST
Created attachment 140416 [details]
original xorg.conf (not working for my setup)
Comment 2 Wojciech Pilorz 2006-11-05 16:11:44 EST
Created attachment 140417 [details]
modified /etc/X11/xorg.conf which works for me
Comment 3 Wojciech Pilorz 2006-11-05 16:12:50 EST
Created attachment 140418 [details]
/var/log/Xorg.0.log with original xorg.conf file (no video visible)
Comment 4 Wojciech Pilorz 2006-11-05 16:13:56 EST
Created attachment 140419 [details]
/var/log/Xorg.0.log with modified xorg.conf file (video visible OK)
Comment 5 Wojciech Pilorz 2006-11-05 17:29:51 EST
Sorry about possible mis-information: I do not know whether it would work with
Fedora Core 4 out of the box.
I have checked that I had Matrox G200 originally when I was installing FC4, and
than changed to Nvidia; The xorg.conf file was most probably vim-ed by me.
Comment 6 Adam Jackson 2007-03-29 18:15:04 EDT
Tough to fix this one.  We're inferring the supported sync ranges from the
monitor's advertised timings, but it's advertising that it supports
1600x1200@75, so that's what we pick, and then it doesn't work.
Comment 7 Adam Jackson 2007-04-10 19:14:44 EDT
So just for interest's sake, does the card work if you use the non-working
xorg.conf in attachment #140416 [details], but with DefaultDepth 16?  I wonder if we're
not hitting memory bandwidth instead of monitor limit.
Comment 8 Wojciech Pilorz 2007-04-11 18:59:25 EDT
Setting DefaultDepth to 16, or both DefaultDepth and Depth (in Display
SubSection) did not help;
If I set screen resolution for a user in KDE or GNOME to some usefule value,
like 1024x786 at 85Hz, then after startx monitors goes off for a second or two
and then on with defined resolution.
If I start X with my modified xorg.conf as was included (and no setting in
GNOME), the monitor starts at 1600x1200, 65Hz.

It is interesting to note, that 
1. While I selected 85Hz in KDE, monitor OSD gives 84.9 Hz
2. X in Knoppix 5.1 seems to behave much better than FC6 on all machines I
tried: besides my home PC with Vanta, Compaq DeskPro with Intel 845,
CompaqProliant 3000 with some ATI: on all these machines FC6 required me to
tweak xorg.conf while Knoppix started out-of-the-box.
Comment 9 Wojciech Pilorz 2008-02-21 14:09:42 EST
In the meantime I have upgraded monitor from CRT to 
a DELL LCD, running at 1280x1024 resolution and 60Hz.
It is running perfectly well with standard xorg.conf.
On the other hand, when I run Knoppix it sets suboptiomal low resolution.
Comment 10 Bug Zapper 2008-05-13 22:27:25 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-06-09 18:20:22 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2009-07-14 12:47:57 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.