Bug 21413 - Error during installation from Hard Disk
Summary: Error during installation from Hard Disk
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-28 08:52 UTC by G.P.S. Murty
Modified: 2007-03-27 03:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 15:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Message during RH-7 installation from the Hard Disk (1.75 KB, text/plain)
2000-11-28 09:01 UTC, G.P.S. Murty
no flags Details

Description G.P.S. Murty 2000-11-28 08:52:43 UTC
Traceback (innermost last):
File "/usr/bin/anaconda.real", line 438, in ?
intf.run(todo, test = test)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in run
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in __call__
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in upgradeFindPackages
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in readComps
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 353, in readCompsFile
File "/tmp/lib/python1.5/urllib.py", line 59, in urlopen
return _urlopener.open(url)
File "/tmp/lib/python1.5/urllib.py", line 159, in open
return getattr(self, name)(url)
File "/tmp/lib/python1.5/urllib.py", line 330, in open_file
return self.open_local_file(url)
File "/tmp/lib/python1.5/urllib.py", line 340, in open_local_file
return addinfourl(open(url2pathname(file), 'rb'),
IOError: [Errno 2] No such file or directory: '/tmp/hdimage///RedHat/base/comps'

Local variables in innermost frame:
mtype: None
self: <urllib.FancyURLopener instance at 90e6230>
mimetypes: <module 'mimetypes' from '/tmp/lib/python1.5/mimetypes.pyc'>
StringIO: <module 'StringIO' from '/tmp/lib/python1.5/StringIO.pyc'>
file: /tmp/hdimage///RedHat/base/comps
url: /tmp/hdimage///RedHat/base/comps
host: None
headers: Content-Type: text/plain

mimetools: <module 'mimetools' from '/tmp/lib/python1.5/mimetools.pyc'>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 1 G.P.S. Murty 2000-11-28 09:01:24 UTC
Created attachment 5769 [details]
Error Message during RH-7 installation from the Hard Disk

Comment 2 Matt Wilson 2000-11-28 19:03:31 UTC
It looks like the /RedHat/base directory wasn't properly copied onto your hard
drive image.


Comment 3 david massicotte 2001-03-09 19:13:18 UTC
I have the same problem. I try to install from the hard disk. Here is the error 
message it gave me:

-----------------------------------------
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in 
readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: diffutils

Local variables in innermost frame:
self: <comps.HeaderList instance at 8243648>
item: diffutils

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
------------------------------------------------------

I dont see what I could try to fix the problem. Please, if you read this and 
have a clue, help me a little ok?!!

my email: davidmassicotte@videotron.ca

I have a Pentium III 128meg 100mgz 13Gig ;
I made the partition with partition magic (/boot (hda1 : 16meg) ; / (hda5 : 
900meg) ; Swap (hda6 : 133meg) )
 thank you


Comment 4 Michael Fulbright 2001-07-02 15:09:45 UTC
It appears you did not setup the hard drive image to install from correctly. The
Install Guide has instructions on how to do this.


Note You need to log in before you can comment on or make changes to this bug.